Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
travbum
Advocate I
Advocate I

Visualization can't remove Time from Date

 

I've split a column in to two parts, "CreatedDate" and "CreatedDate_TimeOnly". When I go to chart the "CreatedDate" it's still giving me times for the data. How do I remove this? 

 

dates and times.png

 

2 ACCEPTED SOLUTIONS

This looks like formatting only. Go to the data view and change the format of the date column to exclude the time format



* Matt is an 8 times Microsoft MVP (Power BI) and author of the Power BI Book Supercharge Power BI.

View solution in original post

v-ljerr-msft
Microsoft Employee
Microsoft Employee

Hi @travbum,

 

You should be able to change the data type of "CreatedDate" column to Date type and format it under Modeling tab by first clicking the column within your fields.Smiley Happy

 

ct1.PNG

 

Regards

View solution in original post

18 REPLIES 18
Faiza_Fatima
New Member

I am facing the same issue

imocean
Frequent Visitor

I took an alternative way - in my Line Chart visual I selected Month and Day as hierarchy, then selected 'flatten all level' for the chart. I then got it displayed in month-date in X axis. Users can always drill up to get to monthly trend too. Hope this helps in some way. 

 

image.pngimage.png

 

 
DanielM80
Advocate I
Advocate I

I have the same issue but the format change didnt fix it. Any ideas?

@DanielM80 Did you change the Data Type or just the Format?

both, but i figured it out last night. The x-axis was set to continious not to category... 

Thanks!

THANK YOU FOR POSTING THIS! I was losing my mind over here

thanks you made my day!!!!

Anonymous
Not applicable

Thanks.  Fixed my issue after changing from Continuous to Category.

DanielM80
Advocate I
Advocate I

Same problem but after changing the format the time remains. any ideas?
v-ljerr-msft
Microsoft Employee
Microsoft Employee

Hi @travbum,

 

You should be able to change the data type of "CreatedDate" column to Date type and format it under Modeling tab by first clicking the column within your fields.Smiley Happy

 

ct1.PNG

 

Regards

@v-ljerr-msft  Hi, I have the same problem. The date is formatted as you say but the visual Measure still gives me the time.

 

ScreenHunter_196.jpgScreenHunter_195.jpg

jopint
Microsoft Employee
Microsoft Employee

When the data range is small (say only 2-3 days), the x-axis tries to be smart so it auto adjusts and inserts time as well. This happens even if the date columns is formated as date only. To solve this, consider switching to categorical (but then dates with no data will not be displayed, thus I do not recommend), or set custom start and end values on the axis.

I am having that same issue. Did you ever get this resolved?

Thanks 

This looks like formatting only. Go to the data view and change the format of the date column to exclude the time format



* Matt is an 8 times Microsoft MVP (Power BI) and author of the Power BI Book Supercharge Power BI.

Changing the data type format from 'DateTime' to 'Date' under the data model view worked.
Thank you!

I've tried everything, changing the type format in formatting, changing the data type and I don't want to change the x-axis to Category. How can I solve this?

If changing the data type/format doesn't resolve the issue - change the x-axis under visual settings from 'Continuous' to 'Categorical'

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

Top Solution Authors