Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Advocate I
Advocate I

Unusual example of the "please rebuild data combination" error

Hello Power BI Community.


I'm having a strange issue with refreshing the data in my model that I hope you can help with:


When I open the report in Power BI Desktop, and then click refresh, I get a refresh error for one or more queries saying "Query ... references other queries or steps, so it may not directly access a data source. Please rebuild this data combination"


However, this is misleading, because after receiving the error messages, I can open Power Query, refresh any source where the preview was cancelled (the ones with question marks against the icons), then close and apply. After doing this, and nothing else, the data refresh will happen without any errors.


It seems therefore that there's nothing intrinsically wrong with the queries.


I've read lots of the normal advice relating to this error message, and have checked privacy levels for the various sources - everything is set to organisational, and as I've explained above, will work on the second attempt when Power Query previews have been refreshed.


In addition, sometimes, some of the queries that error are ones that only access one data source, so the error message shouldn't apply in any case, because the query isn't referencing any others.


If anyone has seen and resolved this behaviour, I'd be very grateful for your input, because I can't find anything online that matches what I'm seeing.


Note: I haven't yet tried refreshing on the Power BI service, as I want to sort the desktop issue before I attempt that.

Frequent Visitor

in my case refreshing the problematic table via power query first solved this issue. 

This can often work as a temporary fix. Where I've used this, the issue will come back next time I work on the dashboard.

Frequent Visitor

2 years and i am still getting the same ridiculous error. Same case and no answers. Same privacy level. I guess this is something to do with a added columns with some M code but this is just dumb. It is still a source like source created via PQ. I have read and watch all theory about folding but as always - these rules don't aplly here. No idea what to do except turns privacy level to off. Still - bad idea. 

Resolver III
Resolver III

I also see this - get the error, look at it in Power Query Editor, error goes away. Since my sources are just links to CSV and Excel files, I think folding can't even apply.


For new builds, I've tried the method of separating merge sources into intermediate queries. This has maybe worked, but given the lack of clarity on why these errors are appearing in the first place, I'm not sure.

Frequent Visitor

I am having the same issue. I also have a dataset built on excel files saved on a SharePoint site location. I imported in Power Query using the standard "SharePoint folder" option under more data sources. Even though I receive the error when using the global "Refresh" button, everything seems to update fine if I click Transform data and just refresh each table's preview in Power Query.


One potential difference is I have only 1 query which actually reaches out to sharepoint. I then have 64 queries (~180 if you count helper queries) that reference the first query as I've found this improves loading time, presumably because it only needs to authenticate with my sharepoint credentials one time.


Another difference is I cannot refresh each table individually from the main Power BI window by right clicking, then Refresh data. The only way it seems to work is if I open Power Query and then refresh previews there.


The issue started occurring yesterday when I was adding new tables. I used the same method I have been using (without issue) for months, as described above. 


Another odd thing is that when I click view errors on the popup, it takes me to Power Query to show the error details, as usual. But the resulting query is blank - there are no actual errors. See attached screenshot.

I'm running version: 2.106.883.0 64-bit (June 2022) installed via executable (not MS Store).



I'm having the issue again today with the August 2023 release...

It raises the error for multiple queries that it can not combine them, then it suddenly seems to be believe that I changed something in powerquery and need to apply changes (although I did not change anything)...

The only way to make the problem disappear (at least briefly) is to go into powerquery edit mode and perform a refresh all which is in my case very time consuming


Does anyone know the root cause in the meantime because it is clear that this does not seem to be an issue with a specific (older) version of PBI desktop

I realized my installation was outdated so I updated, hoping it would fix the issue. But after updating I'm still seeing the exact same issues. 

New version: 2.107.683.0 64-bit (July 2022)

Updated on 7/28/2022:
I tried using the global refresh button again and today it worked without any issues or errors. I have the same installation version (July 2022) so nothing has changed there. Maybe it was a sharepoint issue?

Update again: (8/2/2022)

The issue has returned. I can no longer use the global Refresh button.


Is anyone else having this issue?

Advocate I
Advocate I

Hello all,


Quick update on this issue:


I haven't managed to resolve the actual issue, but I tried refreshing the published dataset in the Power BI service and it worked.  I then set up a scheduled refresh, and it has been refreshing three times a day for a week or so without any errors.


I'm therefore going to leave the queries as they are, and just work around the errors I get on Power BI Desktop.

I am having the same issue you described in your inital post and your reply here. It is frustrating because the error message conflicts with what is actually the case. I think this is just another lousy bug with Microsoft's software. Thank you for the helpful information on the workaround though. It took me a while to realize that refreshing the data in Power Query first would resolve the dreaded "Please rebuild this data combination" error. I will reply back if I ever find a real solution, but I think Microsoft has a bug to work out.

Have a client with the same issue - i can refresh without a problem on desktop but they continually get the errors, any steps to troubleshoot and get around this would be appreciated!

If you're fine on desktop but not in the service, check all the sources have the same permission level. If one credential has a different level it can trigger this.

Community Support
Community Support

Hi @linriss_nr ,



This error can be caused by a number of reasons, such as the data privacy levels between data sources or the way that these data sources are being combined or merged. For more information about how to diagnose this issue, go to Data privacy firewall.


Please check out these two blogs and try the methods mentioned in them.

Power Query Errors: Please Rebuild This Data Combination

Power BI refresh error: Unable to combine data and workarounds


Best Regards,

Community Support Team


If there is any post helps, then please consider Accept it as the solution to help the other members find it more quickly. If I misunderstand your needs or you still have problems on it, please feel free to let us know. Thanks a lot!

How to get your questions answered quickly -- How to provide sample data

I rebuilt all of my data sources following the steps in this post (, and am still having the same issue. I'm reporting back here to hopefully save others some time if they were thinking of trying this.


To reiterate, this issue only happens in Power BI Desktop. The same report is published to the Power BI service and refreshes nightly without ever having an issue. It must be a bug.

Hello @v-cgao-msft ,


Thank you for responding to the post. I've read a couple of those links previously, but am struggling to make use of the advice for a few reasons:

  1. The advice in the links seems to conflict - the Power Query Errors: Please Rebuild This Data Combination  link says to split out queries into a separate one for each data source, but the Data Privacy Firewall  link says that queries must be combined into a single one. These appear to be two opposite courses of action.
  2. Every time I open the Power BI Report and click refresh, different queries generate the error. For example, on Friday, two of the queries errored, whereas yesterday, there were seven with errors. This inconsistency is making it very difficult to work out where to make a change, and to know if that change has worked or not.
  3. As I mentioned in my initial post, the errors go away if I refresh the power query data previews first
  4. Also, if I open the report and refresh the queries individually by right-clicking on each one in the Fields pane and selecting Refresh data, they all refresh without any errors.  After I've done this, the full refresh will then also run without errors.
  5. One of the queries that errors in this report works absolutely fine in a different Power BI report

Because of the above reasons, it's very difficult to know what course of action to take.  In addition, as I can avoid the errors by just triggering individual refreshes first, is there actually anything wrong with the queries at all?


I'm trying to avoid having to randomly split apart and then recombine a whole range of queries in the hope of hitting on a combination that refreshes without issue.


One point that I didn't mention in my original post, but that might help in diagnosing this issue, is that all of the sources accessed by the queries are either excel tables or csv files, located on SharePoint and set up using the Web data source option.


Any further knowledge that you or other members of the Power BI community can provide would be much appreciated.

Honestly, this is a frustrating Power BI bug and it's still around. I can't believe that it hasn't been resolved yet. Before end(ish) of 2022, I had never seen this before, and now it's a pretty common occurrence, even connecting to the same data sources (SQL Server, Data Flows, all Microsoft connections).


Recommending people follow steps to correct the error on their end, especially if that's to refresh first in Power Query (extra, ridiculous step - the desktop refresh button in the reporting canvas should simply work), or splitting/combining queries in a way that isn't intuitive to avoid this issue, are both "solutions" that are avoiding the correction of the underlying issue.


If anyone from the Power BI team is reading this, please don't tell me to "submit and idea and get upvotes so it can be prioritized" - please just use your own product enough to repro this and fix the darn thing.

@ryan0585 wrote:

Recommending people follow steps to correct the error on their end, especially if that's to refresh first in Power Query (extra, ridiculous step - the desktop refresh button in the reporting canvas should simply work), or splitting/combining queries in a way that isn't intuitive to avoid this issue, are both "solutions" that are avoiding the correction of the underlying issue.

YES!!!!! THANK YOU!!!!!

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors