Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
rickylee
Helper III
Helper III

Unable to expand a column (prefix with underscore) in Accounts entity from Dynamic 365 online

Hello,

Happy New Year to you all!!

My power bi is connecting to Dynamic 365 online. I need to expand a column in Accounts entity which I believe it has the id which connects to Connection entity.

At the moment, there is no relationship between tables. I will form a relationship I can manage to expand the columns I need.


I am trying to expand the following columns in account entity:
account_connections1._record1id_value
account_connections1._record2id_value

2019_01_01_14_16_14_test_Power_Query_Editor.png

No matter how many times I try, they stuck... I have been waiting at least 24 hours before clicking cancel since information was no longer downloading. The entity is not huge, it is about 1 GB. 

I also tried to expand the information individually e.g. Expanding account_connections1._record1id_value and then account_connections1._record2id_value. It worked once and I ended up stucking again...

Also, I am unsure what the 'underscore' really mean but I guess it is a representation of a primary/foreign key to a table.

Are there any other ways to solve this problem? It is because I cannot expand the information I need.

Thanks,
Ricky

2 REPLIES 2
rickylee
Helper III
Helper III

Hello @v-lili6-msft, I removed all my tables apart from one account table. The pbix file is 1642KB. I also fiiltered my data based on createdon date. So it has 1.5 year of data only. I successfully expanded : account_connections1._record1id_value account_connections1._record2id_value But it stuck again when I expanded: account_connections2._record1id_value account_connections2._record2id_value Are there anymore example for table.buffer if this is the only solution I could go for? Thanks, Ricky
v-lili6-msft
Community Support
Community Support

hi, @rickylee

It seems that the dataset is too large to run slowly. Your dataset is about 1GB, and from your screenshot,

you had duplicated it again, then merge and expand.

If you could try to filter the dataset and try it again. for power bi pro/ free licenses. there is a dataset size  Limitation

  • Dataset size limit - there is a 1 GB limit for each dataset in the Power BI service.

https://docs.microsoft.com/en-us/power-bi/service-get-data

and you also could have a try by Table.Buffer

https://docs.microsoft.com/en-us/powerquery-m/table-buffer

https://blog.crossjoin.co.uk/2015/05/05/improving-power-query-calculation-performance-with-list-buff...

Please understand that this link is provided “AS IS” with no warranties or guarantees of content changes, and confers no rights.

 

 

Best Regards,

Lin

 

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.