Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Rod-Average
Frequent Visitor

Unable to Publish to Web

Good morning

 

I updated my PBI desktop version to November yesterday.  Aside from the issue already reported of report themes no longer saving when applied, I also have the issue that I cannot now publish anything from PBI Desktop to the web service.  This applies both to reports created in the October release version and reports created in the November version.  I have un-installed PBI and re-installed but no change.  Anyone else having this issue or anyone have a fix for this.

 

Many thanks

 

Rod Average

1 ACCEPTED SOLUTION

Good Morning

 

I have tried going to the Power BI Service and using ‘Get Data’ and that has worked perfectly.  What was happening was I had opened a report is PBI Desktop and then selected the ‘Publish’ option.  What happened then was I was asked to sign in which seemed to go ok.  I did not receive an error message but I did not then get any options to do with publishing (which I did previously).  If I clicked the publish button again nothing happened.  However, if I can publish by using the get data option in the Service that will be ok. 

 

Thanks for your help.

 

Regards

 

Rod Average

View solution in original post

37 REPLIES 37
ezgi
Regular Visitor

I have pro pbi licence. When I try to publish my report to web, I I get the following error screen 

Warning: This embed code was disabled because your organization uses custom links that are not supported by Publish to the web.

Ho can I fix this problem?

ezgi_0-1691667778175.png

 

 

NeilC
Frequent Visitor

The December Update has now corrected the "Unable to publish" issue, that was caused by the November update.

 

Works fine again.

LS
Frequent Visitor

I have exact same issue, the Publish bottom does nothing

As mentioned earlier, I have downgraded the version back to October release which worked just fine. I wouldn't worry so much about the November release as December update should be out there any day (I guess) and I want to believe that it will carry the fix that was required.

Nevertheless, if you still wish to install the November release pls. refer to one of the notes in this thread stating that the fix should be in production already, so you may want to re-install November update again, or just execute a reboot that may fix the problem.

 

Best,

Nir H 

caseycook
Helper I
Helper I

Same issue, have a team of 12 that's affected by this.

nhol
Advocate II
Advocate II

I've started this thread but didn't get an answer about resolution, only that this issue has been succeffuly replicated and it will be resolved. not sure about ETA.

Meanwhile I recommend anyone who is facing this issue, to downgrade to October release. I did it and currently I'm on October update and it works just fine.

Hopefully the December release which should be out there in a couple of weeks (next week maybe) will resolve this whole matter.

 

Thanks!

Nir H

Anonymous
Not applicable

Nir,

Microsoft reported an approximate ETC for a resolution a couple is weeks ago:
http://community.powerbi.com/t5/Issues/Unable-publish-from-Desktop-to-Service/idc-p/302586

Regards,
Angela

Thanks Angela!

So the fix will be available in PROD very close to the December release... I guess this is why I decided to downgarde to October update and skipped the November release.

 

Thanks!

Nir H

Anonymous
Not applicable

You're welcome, Nir!

 

Yes, I recommended to my team to just wait until the December release instead of downloading the November release. I'm not sure why Microsoft even chose to keep the November release up since it's causing so many of us issues. Hopefully, this particular issue will be resolved as planned!

 

Regards,

Angela

Royberghout
New Member

Hi, I'm also just putting in that I'm having this issue as well with the latest update.

nhol
Advocate II
Advocate II

Hello,

 

I just downloaded the latest version of Power BI (as I do every month) and since then the "Publish" button stopped initiating the publish process.

I have another machine with Power BI installed and with an earlier version so I went there and publish my report from there and it worked fine. However, after installing on that machine the latest version as well, it also stopped working...

any idea if this is a broad issue with the latest version of Power BI???

 

Thanks!

Nir

Anonymous
Not applicable

Just putting in that I'm having this issue as well with the latest update.

Rod-Average
Frequent Visitor

I initially marked as solved as the suggestion to use 'Get Data' in the PBI Service worked.  However, this did not work for all reports or all users.  As per my follow up response the next day.  Unfortunately it is not possible to de-select the 'Solved' option.

 

Regards

 

Rod Average

HI @Rod-Average

 

I have the same issue, cannot publish anything to the Power BI Service from PBI Desktop. 

 

Regards, 

 

Matt

Hi. 

 

I have the same problem!! Does anyone has a solution or response from Microsoft?

 

Thanks.

 

I have just installed the latest update (Version: 2.52.4921.682 64-bit [November 2017])which is the second November update.  This has not fixed the publishing issue neither has it fixed the issue of themes not saving when a report is saved.

 

Regards 

 

Rod Average

I have the same issue !!

 

This renders the service completely un-usable....

 

Some help please MS ??

Anonymous
Not applicable

I am expereincing the same issue (the "Publish" buton in PBI desktop does nothing).

 

However, the proposed workaround is no good for me because my report data sources are Azure Analysis Service models.

 

Is this going to be fixed within the month of Novemeber Microsoft?

Rod-Average
Frequent Visitor

Further to my earlier post stating that this issue is solved by getting the data via the PBI Service, apparently this solution only works in some circumstances.  Even if this is the case, the way to publish is to build a report in desktop and then use the publish function.  This is clearly not working properly since the November update.   Any word from Microsoft? 

 

Regards

 

Rod Average 

NeilC
Frequent Visitor

Yes, I am having the same issue too.

 

Strangely, the one file that has the data automatically linked, does allow me to publish. All my other work i do through adding excel files, and none of these can publish. I have a ticket raised with microsoft, and they have confirmed this is a know issue on the back of the November update. Only seems to apply to those on a desktop. Other connected to our management server are unaffected.

 

Still waiting for a solution.

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.