Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Molotch
Helper II
Helper II

The name is already used for a column on table

I made a new power query function and when I try to apply the changes I get this warning on all of my tables. Not all tables have a column named "KundId" and the ones that have only have one. What could be happening and how do I debug this error?

 

 

Capture_small.jpg

8 REPLIES 8
v-sihou-msft
Employee
Employee

@Molotch

 

Based on your error message, you supposes change a column name which exists in a table already. And you may also have reference to this column in some calculations within other dataset so that other tables will also throw error related to this column. Make sure your change the name of this referenced column in all measures/calculated columns.

 

Regards,

Hello,

 

I am having the same error message. I actually want these two columns to merge under the same name.

 

I have three queries. "Query 3" is a merge of "Query 1" and "Query 2". I just added a column named "Goals" to both "Query 1" and "Query 2". They match in data type (Int64.Type), and the spelling is the same. When I update "Query 3", instead of matching the columns, and merging into one, it gives me the error described above.

 

Do you have any advice on this?

Anonymous
Not applicable

@avalos , is there a column named Goals already available in Query 3 ? Your Query3 should not have any column (Either native or Calculated column)

There is no column named Goals in Query 3. It is created when merging 1 and 2.

 

Thank you for the follow-up. I try a few times to update and run it, and it just worked. It was maybe a bug.

Anonymous
Not applicable

Thanks, i had similar issue. 

 

I had a calculated column which is named same as the column i am trying to load from Power Query. I renamed the calcualted column and loaded the data and it worked.

 

Thanks,

Nishanth.

Anonymous
Not applicable

This solved my problem.
Thanks

Baskar
Resident Rockstar
Resident Rockstar

Cool, 

 

Check the table have same column more than one.

If u have same name in multiple table that doesn't make prob. if u have in under single table that is the prob.

 

Note:

Download latest Power BI file and lets try.

 

MarcelBeug
Community Champion
Community Champion

It's hardly visible, but it looks like the issue is with the 'Faktura' query.

I guess there are dependencies with other queries, so that would be the reason for the error to pop up for those queries as well.

My suggestion would be to investigate the 'Faktura' query and find the first erroneous step.

Specializing in Power Query Formula Language (M)

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.