Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
Kerslaing
Helper I
Helper I

Slicer not working with time intelligence measure

I am trying to display a straightforward table that shows the time to resolve a ticket by week,  the resolve time in minutes in our database and ive used other posts in the forum to get that to display and sum up in hh:mm  and that is working fine,  however as soon as i add the hh:mm resolve time the slicer stops working and instead of only seeing results for the selected week i see all the records in the table but with no data in the resolve time apart from for that week.  The week slicer is coming from a date table that is joined to the database table  both using date fields.

 

Using just the minutes and a decimal time it works fine - see below

 

Kerslaing_0-1669379558550.png

 

If i add the hh:mm measure to the table i get this

Kerslaing_1-1669379680597.png

if i scroll all the way down to the 7/11/22  records the data is there but why are all the other records showing and not being filtered out by the slicer 

Kerslaing_2-1669379902180.png

 I have tried moving the measure from a measures table to within the facts table, ive tried changing it to column from a measure, redone the relationships and checked that joins are all using the same date type. 

Kerslaing_3-1669380046396.png

 Can anyone point me in the right direction to sort the filtering?

6 REPLIES 6
HotChilli
Super User
Super User

Can you put a sample file together and post a link?  I'll have a look

hi, heres a sample pbix  - https://www.dropbox.com/s/f9d40oz2z751tow/RI-time.pbix?dl=0 

You can see wheeve i use the slicer it does not remove the records from the table.

I appreciate the file being provided. Thank you.

The measure is returning ':' even when there are no hours or minutes.  So powerbi is still going to show the row.

It needs to return a blank or blank() if there are no values for hours/minutes.  That should sort it.

thats strange, i removed the : h,m  previously and it still returned the rows.  However this time it is removing them, but i also removed the format command to pad out the hours and it has removed the rows, which is great but i need some sort of formatting at i cant display 1 hour 20 minutes as 0120  it needs to have some sort of formatting.  How is that possible but still removing the rows

Kerslaing
Helper I
Helper I

even if i remove the formatting to still displays the empty rows

Kerslaing_0-1669391448590.png

 

HotChilli
Super User
Super User

powerbi removes lines from a visual if a measure returns blank, so it looks like there is a default value (h,m) returned in the measure. That's why all the 'extra' lines are showing.

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.