Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
vincentnoot
Resolver I
Resolver I

Sharepoint authentication error "We couldn't authenticate with the credentials provided"

Hi all,

 

I have several reports using files from Sharepoint as a data source. I used to have Organizational account setup for authentication, which worked perfectly for a long time.

All of a sudden, this authentication stopped working when I tried to import a new Sharepoint file. I've tried removing the authentication settings as suggested in other posts. This unfortunately destroyed all Sharepoint connections I had setup which means none of them are working now.

As soon as I try to authenticate through Organizational, Basic or Microsoft Account, the prompt gives a "We couldn't authenticate with the credentials provided" error.

I've tried several things so far but nothing seems to work.

I can access the Sharepoint site without issues with the same credentials, so that doesn't seem to be the issue.

 

 Source = Excel.Workbook(Web.Contents("https://Contoso.sharepoint.com/sites/Innovation/Shared%20documents/General/Datasets/" & #"CustomerName" & "/hours.xlsx"), null, true),

1 ACCEPTED SOLUTION

Hi,

 

My issue was different from the one described in the post you link.

Appartently it was an issue with the Edge authentication prompt. I fixed the issue by changing my default browser to chrome and in Power BI go to Settings > Security > User my default webbrowser.

This fixed the issue.

View solution in original post

15 REPLIES 15
CHay
New Member

Hey all if you are still having issues with this you can go to 
Transform data > right click on your table and click advanced editor > check your url there


https://company_sharepoint.com/:x:/r/sites/ConnectedWorker/Shared%20Documents/Device/Device%20Alloca...

 

if it looks like this delete the /:x/r/ or whatever similar file path you have there 

if this doesn't work you can clear permissions that may work good luck

TrueBlueWoman
Regular Visitor

One other option that might work for this is that if your SharePoint list columms is linked to other areas of SharePoint, you can remove those columns. It's possible that those areas are restricted and even though you're not utilizing the underlying information, it may be preventing you from accessing that data. I removed those fields that could be expanded and my error went away.

Thank you for this! I never would have figured out this was my issue after trying to connect over and over again. A different error should be displayed when this happens. 

Anonymous
Not applicable

I am also not able to the use the function Web.Contents with SharePoint because I could not be authenticated even when using Chrome. Any other solution?

v-yanjiang-msft
Community Support
Community Support

Hi @vincentnoot ,

Please see if this similar thread helps.

Best Regards,
Community Support Team _ kalyj

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Am I missing something here? Neither this post or the one you link to seem to provide a working solution to this issue. Wondering why theye're both marked as resolved?

Hi,

 

My issue was different from the one described in the post you link.

Appartently it was an issue with the Edge authentication prompt. I fixed the issue by changing my default browser to chrome and in Power BI go to Settings > Security > User my default webbrowser.

This fixed the issue.

The replie's provided were not a valid solution.  I have the same problem and my company will not allow us to change our default browser to Chrome.  We are forced to use Edge and I cannot get past this error.  

Anonymous
Not applicable

Same. My organization will not allow us to change our default browser from Edge to Chrome or any other browser.  There must be another solution.  Maybe clearing cache?

You have to use the url up to the point where it says "sites". This is usually the parent folder. Once you used that URL, you will be able to access all files in each subfolder.

I'm in the exact same situation. I've cleared my cache, cleared permissions for SharePoint, updated my default brower from Explorer to Chrome. I've even gone as far as connected to SharePoint through OData, this worked termporarily and I'm back at square one. Anyone have any concrete solutions?

I responded to an earlier post and someone recently stated this worked for them:

"One other option that might work for this is that if your SharePoint list columms is linked to other areas of SharePoint, you can remove those columns. It's possible that those areas are restricted and even though you're not utilizing the underlying information, it may be preventing you from accessing that data. I removed those fields that could be expanded and my error went away."

Thanks. I tried this solution but I am still getting the same error. Is there anything else I can try?

Great! This fixed my authentication issue too. Thanks a lot 😊

I had the same issue and this method solved it. Thanks a lot !

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.