Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
tessahurr
Employee
Employee

Share your thoughts on DirectQuery for Power BI datasets and Azure Analysis Services (preview)

Hit Reply and let us know what you think of the DirectQuery for Power BI datasets and Azure Analysis Services.  To learn more about this feature, please visit this blog post or our documentation.

 

Here are some areas that we'd like to hear about in particular:

  • Performance
  • Query editor experience--the remote model query doesn't show up in the query editor and only in the data source settings dialog. What are your thoughts?
  • Navigator experience
  • Thoughts around governance and permissions for models that leverage this feature
  • Nesting models, i.e. building a composite model on top of a composite model
  • Automatic page refresh for live connect in composite models

Thanks and we look forward to hearing your feedback!

 

- The Power BI Modeling Team

531 REPLIES 531
MiraNi
Advocate III
Advocate III

I have received error "Sequence contains no elements", when refreshing the Power BI datasets in composite model. This did never happen with May version of desktop but occurred after upgrading to October and again to latest version published about a week ago. 

 

Feedback Type:
Frown (Error)

Error Message:
Sequence contains no elements

Stack Trace:
System.InvalidOperationException
at System.Linq.Enumerable.Single[TSource](IEnumerable`1 source) etc.

Now this error message doesn't appear anymore but instead everytime I open the file, I get a new error 'Error getting value from 'CanDelete' on 'Microsoft.PowerBI.modeling.Engine.DataModel.Table' Error getting value from 'CanDelete' on 'Microsoft... - Microsoft Power BI Community

kost
Frequent Visitor

I am getting an error "An error occurred while loading the model. Verify that the connection information is correct and that you have permissions to access the data source." while trying to activate model editor with "Make changes to this model" to Push Dataset in Power BI Service.

melany
Advocate I
Advocate I

When the composite dataset is refreshing, the visuals will not load until the refresh is over.  This can take easily over 10 mins depending on the dataset.  Is there a way to remedy this so the end-user does not think the report has a problem?

melany_0-1634239005093.png

 

adriantheuma
New Member

We are having a problem with DirectQuery for Power BI datasets for large tables. In the screenshot below 'Account Attributes' has 6M rows and 'Retail Sales' has 24M rows. 

 

Retail Sales is in a separate PBIX file that is loaded on the Power BI service. 

 

When we try to use attributes from the 'Account Attributes' table or refresh the 'Account Attributes' table the report does not refresh. The 'Account Attributes' table would normally refresh in a minute or so but since moving the 'Retail Sales' table to a separate PBIX file the refresh remains in the status shown in the screenshot below and does not complete.

 

There are no issues when refreshing or using attributes in the report from the other tables connected to 'Retail Sales', such as the 'Date' table. These are all tables that have a few hundred rows.

 

Is there a service limitation on the size of the tables that can be in separate files?

 

adriantheuma_1-1632208909387.png

 

 

Looks like I have answered this myself. Will this improve for composite models? 1M rows is a bit restrictive.

 

Feedback Type:
Frown (Error)

Timestamp:
2021-09-21T08:21:50.6919927Z

Local Time:
2021-09-21T18:21:50.6919927+10:00

Session ID:
39705183-f0c9-4b74-8532-e8249d95ab8f

Release:
August 2021

Product Version:
2.96.1061.0 (21.08) (x64)

Error Message:
The resultset of a query to external data source has exceeded the maximum allowed size of '1000000' rows.

OS Version:
Microsoft Windows NT 10.0.19041.0 (x64 en-US)

CLR Version:
4.7 or later [Release Number = 528372]

Peak Virtual Memory:
105 GB

Private Memory:
997 MB

Peak Working Set:
1.24 GB

IE Version:
11.789.19041.0

User ID:
b39f14f6-ec17-4057-b5eb-030a835a41ae

Workbook Package Info:
1* - en-AU, Query Groups: 0, fastCombine: Disabled, runBackgroundAnalysis: False.

Telemetry Enabled:
True

Snapshot Trace Logs:

Model Default Mode:
Composite

Model Version:
PowerBI_V3

Performance Trace Logs:

baouss
Frequent Visitor

I just now wanted to try this out but cannot get it to work. There is one push dataset I connect to using the latest version of PBI Desktop (the preview flag is enabled). After adding the dataset, `Get data` is greyed-out and I do not have the option to add other data sources.

interesting, can you please open an issue so we can investigate?

KaweckiM
Regular Visitor

Like the new Direct query feature and are using it extensively .. however Want to describe an issue we are having that is concerning for us as it makes testing changes to a dataset attached in direct query very difficult 

 

Normally we ..

step1 test modifications we make to a dataset by re-pointing existing ** reports at the modified ‘DEV’ dataset and Verify that they still work correctly .. if all good ..

step2  then we publish  overlay  ‘Prod’ dataset with dev dataset  .. and existing prod reports are good to go

**These reports are normally live connections to same dataset.

 

Issue is when the report is a  Direct Query local Model .. it throws an error in step1 (see below) even when the ‘Dev’ dataset is exactly

The same as prod  (so the ambiguous path error we receive is not valid error)… if we go ahead and overlay prod with dev … the prod reports

don’t throw an error and work fine .. but if they don’t I’m afraid we have no way to recover . as we can’t connect to an alternate datasource.  In fact I suspect that even if we restored the prior Version of the dataset the direct query local model reports would not be able to connect to it.. and we would have to re-create them basically from scratch

 

Pls advise if you have heard of this issue and if there is a workaround..

 

**Note Datasource that we are replacing in the direct query local dataset  is an incremental

   

KaweckiM_0-1630108149108.jpeg

Error Returned 

KaweckiM_1-1630108299549.png

 

 

so, the error says you have an ambiguous path. Is that true? Is so, you will need to redesign it.

no ambiguous path .. it is an exact copy of the dataset being used in the direct query model published under a different name in a different workspace.  

sorry for the late reply - please open an support ticket so we can investigate this.

MLechner
Frequent Visitor

Hi team,

we had the following scenario:
We created a "golden dataset" that we use in some dashboards. If we now connect an additional data source to the dashboard an extra dataset is created for it, which makes sense, yet we have a strange phenomenon. We have set the permission for both datasets to "Read". But the users can't see the data of the "Golden Dataset" in the new dashboard. Only when we set the permission of the users in the Golden Dataset to "Build", they can see the data. Of course, this is not desired because we want to prevent users from creating their own dashboards with the dataset.

 

Are you aware of the problem ?

 

Greetings

Markus

this is a known issue and we're investigating a fix.

Jeroen — this is the main issue blocking our use of this feature in production. We have MANY datasets and analysts want to add their own lists but build permission is not an option. 

This is a known issue, please upvote this idea to help prioritize it:

Microsoft Idea  · Directquery for datasets only needs read permissions on all datasets (powerbi.com)

 

Hi MLechner, 

 

We have the same behaviour and to my knowledge there isn't another way around it at the moment, which is frustrating...

m_b
Regular Visitor

This is a great feature, when using/testing it I run into the following problem though.

 

- I connect to an Azure Analysis Services tabular model

- Then I add a calculated column to a fact table using RELATED to add a value from a dimension table within the same model which has a one to many relationship with the fact table, no errors appear when doing this

- As soon as I try to use the calculated column (or something using it) in a visual this error appears:

 

m_b_0-1629179867250.png

 

- The strange thing is that this does work when doing the same thing but with a different dimension from the model (no error appears when using it)

 

What can cause this error? As far as I can tell I'm not doing something that isn't supported and as I'm referring to a table within the same model I don't see any issues (no limited relationship).

 

One thing that is different between the dimension for which this works and the one for which it doesn't: the key in the fact table which relates to the dimension which doesn't work has blank values as the dimension isn't applicable for all the rows. In this case I expect RELATED to return a blank value. Also I'm pretty sure this worked when I tested it earlier in the year.

 

Hopefully you can help me with this, thanks in advance!

we were unable to reproduce this - can you please open an issue for this so we can collect some more info?

Sure, do you mean I should post it on Issues - Microsoft Power BI Community or should I open a support ticket?

either works - but support ticket is faster.

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors