Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
olimoz
New Member

Publishing always results in "Unable to write to the transport connection"

Hi,

 

I'm cannot appear to publish any reports. Whichever report and whichever desktop PC I attempt to publish from, I get:

"Unable to write to the transport connection.  An existing connection was forcibly closed by the remote host".

 

I can log into PowerBI online without problems, so I know my credentials are fine.

 

Is this my error, or something else? 

 

Oli

 

BackendUrl
https://wabi-north-europe-redirect.analysis.windows.net/

2 REPLIES 2
v-yuezhe-msft
Microsoft Employee
Microsoft Employee

Hi @olimoz,

Please go to File -> Options and settings -> Options -> Diagnostics and click "enable tracing", then publish your PBIX file and check the detailed logs in the traces folder. Also please help to post the detailed logs here.

In addition, the above error could also occur when the PBIX file is greater than the file size that Power BI Service supports.  Please make sure that your PBIX file size is within 1GB.

Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
a_mixed_life
Resolver I
Resolver I

I'm still dealing with the exact same issue as your. Where no matter which PBIX file I have when I publish from my PowerBI Desktop, it gives me this same error.


However when I created a NEW powerbi, I'm able to publish. When recreating my pbix file, it gives me the same error.


What I found out is that I think it has something to do in my internal network (Firewall, DNS, etc.) because when I'm outside the network with the same files, I'm able to publish.

Kris

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

Top Solution Authors