Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
CHauser
Regular Visitor

Preventing text box from coming to the front & hiding visualizations like slicer(s)

I'm trying a textbox as my background at the top, containing slicer(s).  But each time I click somewhere other than directly on a slicer the textbox comes forward and essentially hides the visualizations that reside 'within' the textbox border.  This requires clicking somewhere off the texbox to return the slicer(s) visually.

Is it possible to prevent this behavior so the text box remains in back of all other visualizations even when clicked?

Maybe I should try using something other than a text box to accomplish this?

1 ACCEPTED SOLUTION
Watsky
Solution Sage
Solution Sage

Hi @CHauser 

To prevent a visual from coming to the foreground you can adjust the layer order then set it to maintain the layer order.

  1. In Power BI at the top click View Watsky_0-1659473835257.png

     

  2. Under Show panes, click Selection. Watsky_3-1659473949762.png

     

  3. Make sure that your Text box appears at the bottom of your layer order list. Watsky_2-1659473936542.png

     

  4. Click on your Text box visual. On the Format pane under Advanced options click Maintain layer order so that it is set to On. Watsky_4-1659474085258.png
  5. Publish your report. 

It's important to note that by clicking on the unpublished report you won't notice that anything has changed. However, once published you'll see that the Text box no longer comes to the foreground. Hope this helps.


Did my answer(s) help you? Give it a kudos by clicking the Thumbs Up!
Did my post answer your question(s)? Mark my post as a solution. This will help others find the solution.

Proud to be a Super User!

View solution in original post

2 REPLIES 2
Acroustique
Frequent Visitor

That's brilliant, thank you for the tip @Watsky ! 🙏

Watsky
Solution Sage
Solution Sage

Hi @CHauser 

To prevent a visual from coming to the foreground you can adjust the layer order then set it to maintain the layer order.

  1. In Power BI at the top click View Watsky_0-1659473835257.png

     

  2. Under Show panes, click Selection. Watsky_3-1659473949762.png

     

  3. Make sure that your Text box appears at the bottom of your layer order list. Watsky_2-1659473936542.png

     

  4. Click on your Text box visual. On the Format pane under Advanced options click Maintain layer order so that it is set to On. Watsky_4-1659474085258.png
  5. Publish your report. 

It's important to note that by clicking on the unpublished report you won't notice that anything has changed. However, once published you'll see that the Text box no longer comes to the foreground. Hope this helps.


Did my answer(s) help you? Give it a kudos by clicking the Thumbs Up!
Did my post answer your question(s)? Mark my post as a solution. This will help others find the solution.

Proud to be a Super User!

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors