Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
Anonymous
Not applicable

PowerBI freezes up when I open it over a remote connection

I have a new desktop computer that I use for remote work. I am supposed to connect to a computer in my office via Windows Remote Desktop Connection. Friday was the first day I had this computer, and the remote connection was not yet set up. So I set up a practice project on the computer without the connection.

 

But today, the remote connection is up and running, so I booted it up. Then I went to open up PowerBI. It did open up just fine. But the moment I clicked out of PowerBI to find the dataset I would be using, the software froze up. Luckily I was able to force close it using the task manager. Then I opened PowerBI again and went to find the dataset again, and it froze up again!

 

I need the software to work within the remote connection so I can use it for my job.

6 REPLIES 6
daamruth
Helper II
Helper II

May I ask which verson you are running? I had that issue with some of the former versions as well. It was fixed end of March I think. 

 

Currently running on June 2022 version I have no problems like that anymore. 

 

Cheer

Daniel

Anonymous
Not applicable

Hi @daamruth,

I am using Version 2.106.582.0 64-bit (June 2022).

OK 😞 

 

Have you tried deactivating the preview feature "Power I Desktop infrastructure update"? 

 

Daniel

Anonymous
Not applicable

Daniel,

Please read below for my response to Jing. It seems my problem fixed itself.

v-jingzhang
Community Support
Community Support

Hi @Anonymous 

 

If you want to work on Power BI Desktop within the remote connection, you need to install Power BI Desktop on the remote computer. Has this been done? 

 

"But the moment I clicked out of PowerBI to find the dataset I would be using, the software froze up. " What do you mean by the "dataset"? Do you want to open an existing report (pbix file) in the remote computer? Is this file on the remote computer or on the current new desktop computer? 

 

Best Regards,
Community Support Team _ Jing

Anonymous
Not applicable

Jing,

Here's what I did, in the order I did it:

 

  1. I opened the remote connection.
  2. I went online to find and download the Excel file I would be using for data.
  3. I opened a new instance of PowerBI, which came pre-installed on the connected computer.
  4. I clicked back to the web. This required me to click off of the screen on which I was using PowerBI. So PowerBI was still open, but it was not the app I was looking at.
  5. I made sure I had downloaded the correct dataset.
  6. I clicked back to my instance of PowerBI, which was already open.
  7. I moved my mouse over a button on the top ribbon. The button did not highlight like it should have.
  8. I clicked on the button. The computer made the same noise it makes when you click somewhere invalid, and it did nothing else.

Then after I force closed PowerBI using Task Manager, I did the following:

  1. I opened a new instance of PowerBI.
  2. I clicked onto the web again, just to see what would happen.
  3. I moved my mouse down to the PowerBI icon on the taskbar. It showed a small preview of the new instance of PowerBI that I had just opened.
  4. I moved my mouse upwards to click on the preview.
  5. As soon as I moved my mouse above my taskbar, the preview disappeared and I was unable to click on it. This happened several times until I finally gave up.
  6. I ended up opening Task Manager again and force closing the software again.
  7. I wrote this post.
  8. I closed the remote connection entirely and started working with the same dataset on just the computer. Everything worked smoothly from there.

Now, here's what happened today when I tried to recreate the problem:

  1. I opened up the remote connection.
  2. I downloaded my dataset into PowerBI.
  3. I transformed the data to make sure I could.
  4. I clicked onto the web to continue writing this comment. Again, PowerBI is still open, but it is not on my screen at the moment.
  5. I moved my mouse to the PowerBI icon in the taskbar. I saw the preview of the new instance I had just opened. I moved my mouse up to click on the preview, and it disappeared.
  6. This happened three times. On the fourth attempt, the preview did not disappear, and I clicked on it.
  7. I switched back to my new instance of PowerBI and proceeded to click around on different buttons, and they all did what they were supposed to do.

Thanks for your response. If you have any thoughts on why the computer might have been acting up, I would be interested to hear them. But it looks like my issue resolved itself and all I needed to do was wait.

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.