Forum Discussion
Power BI Report server - Issue with deploying power bi report
Hi Guys,
I recently installed a PBIRS Instance (CTP) and SQL 2017 on the same virtual machine in order to try out the new PBIRS and create/deploy some sample PBIX reports to this on-prem PBI server. I'm running into the same problem as rest of the people here. Everytime I create a PBIX report using the June 2017 version of PBI Desktop and try to deploy to on-prem PBIRS instance, I am presented with a very generic error message. When I dig in to the RS log files, this is what I see:-
--------------------------------------------------------------------
2017-06-19 16:13:41.6659|INFO|1|Setting Symmetric Key
2017-06-19 16:13:41.6779|INFO|1|Setting up Hosted Process State
2017-06-19 16:13:41.6779|INFO|1|CFG : rsConfigFilePath = [C:\Program Files\Microsoft Power BI Report Server\PBIRS\ReportServer\rsreportserver.config] (env)
2017-06-19 16:13:41.6779|INFO|1|Attempting to read Configuration from file C:\Program Files\Microsoft Power BI Report Server\PBIRS\ReportServer\rsreportserver.config -> C:\Program Files\Microsoft Power BI Report Server\PBIRS\ReportServer\rsreportserver.config
2017-06-19 16:13:41.9550|FATAL|1|Could not start PBIXSystem.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Net.HttpListenerException: Access is denied
at System.Net.HttpListener.AddAllPrefixes()
at System.Net.HttpListener.Start()
at Microsoft.Owin.Host.HttpListener.OwinHttpListener.Start(HttpListener listener, Func`2 appFunc, IList`1 addresses, IDictionary`2 capabilities, Func`2 loggerFactory)
at Microsoft.Owin.Host.HttpListener.OwinServerFactory.Create(Func`2 app, IDictionary`2 properties)
--- End of inner exception stack trace ---
Is there a patch for PBIRS I can download in order to fix this issue? I read through the responses from Msft team here in this thread and I concluded that they have a patch to fix this without me having to change some settings/service accounts on the server?
Hey Muqadderlqbal, the GA version of Power BI Report Server has a fix for this issue however you can fix it with the May preview versions of both SQL 2017 and PBIRS as well. If you read my previous post it has the steps to clean this up:
Let me know if this doesn't work for you.
Matt M.