Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Frequent Visitor

Power BI Desktop doesn't load all the data from dataflow

Hi everyone,


I have a dataflow on a workspace premium capacity.

I have a pbix file and I take all the data from the dataflow.

I added a new table in the dataflow, everything perfect, all the data is in it after all the calculations.


But when I tried to load this table in Power BI desktop, just 20% of the rows are loaded.

I tried from another blank pbix file and it happen the same thing. Exactly the same data are loaded in it but it represent about 20% of the whole table.

I don't do any calculations on it (in PBI Desktop) and it is just like that.


I don't really have more info to give you... I investigated and didn't find anything...


Did this already happen to someone?


Thank you in advance


Regular Visitor

I am also facing the same issue, i have 2M rows of data and power bi takes whole day for loading the data, when modifying the query ex. changing the datatype, it takes whole for loading and validating the result.  hence i have filtered the data for 100 rows in dataflow and use the data, still it takes whole day for loading.  i am not able to understand the why it behaving so, can any one help me. 

Resolver I
Resolver I

Ensure that the dataflow itself is refreshing correctly in the Power BI service. If the dataflow doesn't refresh properly, the data won't be available for Power BI Desktop to load. Verify that you have the necessary permissions to access the dataflow.
Dataflows often rely on query folding to optimize data retrieval. If a specific transformation or operation isn't supported for query folding, it might lead to incomplete data loading.Check if there are any filters applied within the dataflow. Filters can limit the data that's available for import into Power BI Desktop. Be aware that there is a size limit for dataflows in Power BI. If your dataflow is too large, it may not fully load into Power BI Desktop due to memory constraints. You can try to reduce the size of your dataflow by filtering or aggregating the data. Check for any connection errors or warnings in Power BI Desktop when you attempt to load data from the dataflow. In Power BI Desktop, when loading data from a dataflow, there are advanced options available. Make sure you review these options to see if any settings are affecting data retrieval, such as filters.

Not applicable

Thank you for the feedback... I will review the configuration settings. What I ended up doing was: I opened the dataflow, saved it then refreshed the dataflow. I was then able to pull down the information into desktop and see it in the service.
Helper I
Helper I

What I ended up doing was saving a .json of the dataflow and then deleting the original dataflow. Used the .json to create a new dataflow and then it worked.

Not applicable

Hi, I did the same and it occurred with the new dataflow created from the json. My next step is to completely rebuild the dataflow as I suspect it has become corrupted in some way. Other teams have experienced the same issue in separate workspaces using json copies and pbix copies.

Not applicable

This is also occuring cloud dataflow to cloud pbix...

Helper I
Helper I

I have this exact same issue. My dataflow has ~15M rows but Power Bi desktop is only retrieving ~4M rows. Power BI Desktop only connects to the dataflow for this table without any filtering.

Super User
Super User

@arthurld , first of making sure dataflow is refreshed properly and has full data .

Also open power query and check any error in loading

@amitchandak thank you for your answer.

There is the right amount of data into the dataflow, the refresh is ok.

And I checked Power Query ther is no error in loading, and as I said, it happens exactly the same in other reports when I'm loading the same table. The same rows are not loaded...

This is really unbelievable, everything looks like everything is ok! But there is just not all the data in the table... I really don't understand how it's possible

Hi @arthurld,


Could you try turning off the Incremental refresh and do a full refresh and check if you can see the data.

Not applicable

Any idea what is causing this issue?  I am experiencing the same issue.  Co-worker confirmed this occuring on his end to...

Not applicable

Fixed the issue...

Data was in dataflow but was not showing in the dataset when pulled from the service.
Final Solution: I opened the dataflow, saved it then refreshed the dataflow.

A root cause was not found... I suspect something in the environment corrupted the dataflow... 

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.


Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors