Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started


Pending Changes 'Privacy Levels' Error

I have a recurring problem with an exsiting PowerBI where it is telling me that there are pending changes in my query that I haven't applied.

I click apply changes and the Load is successful but the pending changes still appears.

When I click Discard changes it tells me I have made changes to the privacy levels and despite applying these and them being successful. If I click discard it breaks of my relationship and I don't know how to stop this happening.

I have went into the Power Query Editor and validated the Privacy Levels, I click Apply and Load again and it is again successful but still the issue persists.


It seems to be affecting a table where I have merged other datasources to it in order to build relationships with other tables. However because these changes won't apply despite being successful I am missing data which I can see is populated in the Power Query Editor but this doesn't not load to my report for some reason.


Has anyone experienced this before and know how to fix this issue?




New Member

 I had the same issue. The warning went away once I saved (not close and apply but actually saving) my power query editor in which I had made the privacy settings changes

Community Support
Community Support

Hi @Thomas-B-Hudson ,


Please read this document to evaluate whether to configure the privacy level for the data source.

Understand Power BI Desktop privacy levels - Power BI | Microsoft Docs


If the data does not contain highly sensitive or confidential, you can choose to Ignore the Privacy levels and potentially improve performance.


Best Regards,

Community Support Team


If there is any post helps, then please consider Accept it as the solution to help the other members find it more quickly. If I misunderstand your needs or you still have problems on it, please feel free to let us know. Thanks a lot!

How to get your questions answered quickly -- How to provide sample data

Not applicable

Doing this is what is causing the problem.   Unless you go back to "Combine data..." the "Pending Changes" messages si there.   


We're looking for a solution when we want to ignore the privacy levels (some queries won't work otherwise). 

The only way to fix this is to open the file in Power BI Desktop and then:

  File -> Options and settings -> Options -> Current File -> Privacy -> Combine Data according to your privacy levels for each source.

The feature described in the link above does not work.


If you try to Ignore the Privacy levels, you get an error that cannot be removed.

I ran into the same error but Combine Data was already selected. When I clicked Ignore the Privacy Level settings, it fixed the error. Strange that my solution was opposite yours.

Worked for me also. Thanks! 

This solution worked! Thanks

Super User
Super User

@Thomas-B-Hudson , Go to Data source connection -> clear permission and do it again and save.


You might have set it on service under datasource setting.

This feature does not work.  The only way to fix this error is to combine privacy settings for each source.  Setting permissions  for each data source to None and trying to ignore privacy settings does not work as described in Microsoft's documentation.  

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.


Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors