Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
Morato
New Member

POWER BI Registration page

Dear Community,
I purchased a new notebook and installed the Power BI, as the previous one. However, this new installation began to behave differently from the old one. The program when you start, displays a page with the title "Welcome to Power BI Desktop", with fields to be filled, if you do not have a registered account, and with the option to enter, if you already have a registered account. Only after that is the usual entry page appears.
I have no company account to register, because I am retired and study the Power BI for pleasure, as a complement to Excel, which I am passionate.
I would like to know how to make this homepage of "Welcome" is no longer displayed, because in the previous notebook it did not happen.
Grateful for any help.

 

Note: Translated by Microsoft Translator Smiley Happy

 

Power BI - Página Bem Vindo.jpgPower BI - Página Bem Vindo-Sequência.jpgPower BI - Página Inicial.jpg

1 ACCEPTED SOLUTION

Hi @Morato,

 

Fortunately, we have a good way to disable the dialog by using a key in windows registry. You could hav a reference in this article  How administrators can manage the Power BI Desktop sign-in form.

 

Please note that you 'd better make a backup before modifying the registry.

 

I have tested this way by creating a new key Power BI Desktop under the path HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft and set the value to be 0.

 

Untitled.png

 

 

After you have modified the regedit , you 'd better restart your device then you open Power BI Desktop, the welcome page will not display.

 

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6
quentin_vigne
Solution Sage
Solution Sage

Hi @Morato

 

Here is the help page in your language : https://docs.microsoft.com/pt-pt/power-bi/service-self-service-signup-for-power-bi

Hope this helps

Dear Quentin_vigne,

 

On the quoted page the statement is clear:
What do you need to sign up for?
To sign up for Power BI, you need a professional email address. A personal email address will not work to register with Power BI.

 

I don't have a professional email address only personal.

 

That is why I asked for help in opening up the Power BI Desktop program, no longer applying for this application, which was not required before.

 

I'm still waiting for some help.

 

Grateful

 

Note: Translated by Microfost Translator Smiley Happy

Hi @Morato,

 

To make this homepage of "Welcome" is no longer displayed, you could click the 'Close' icon on top right corner for each Page.

 

Actually, we could use Power BI Desktop without sign in. However, if you want to sign in Power BI Service, you need to have an account.

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-piga-msft,

As I do not want to enter the Power BI service, I would like the homepage "Welcome" no longer start with the application, but its indication is not possible to effect, because the first page does not have the icon "Close" in top right corner.

 

To close this page only by using the ALT+F4 or by clicking the link "Do you already have a Power BI account? Come in". Unfortunately, the pages "Welcome" and  "Enter", are having to be closed at every startup of the Power BI Desktop.


In previous installations, this "Welcome" page did not appear, only after the May/2018 update (version: 2.58.5103.501 64-bit) is that it came to emerge at each startup.

The Excel program accepts parameters on the command line that change the way it is opened.
Does the Power BI Desktop also have any alternative in this sense?
Or is it possible to make any changes in the way you start by changing any parameters in the Windows registry?

 

I'm still waiting for some help to solve this problem.
Grateful.

 

Note: Translated by Microsoft Translator Smiley Happy

Hi @Morato,

 

Fortunately, we have a good way to disable the dialog by using a key in windows registry. You could hav a reference in this article  How administrators can manage the Power BI Desktop sign-in form.

 

Please note that you 'd better make a backup before modifying the registry.

 

I have tested this way by creating a new key Power BI Desktop under the path HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft and set the value to be 0.

 

Untitled.png

 

 

After you have modified the regedit , you 'd better restart your device then you open Power BI Desktop, the welcome page will not display.

 

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-piga-msft

By virtue of their instruction, I found in the registry the key ShowLeadGenDialog in the path HKEY_CURRENT_USER\Software\Microsoft\Microsoft Power BI Desktop. It was only to set the value 0 that the problem ceased to exist.
I'm very grateful for your help.
Best regards
Morato

 

Translated by Microsoft Translator Smiley Happy

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.