Forum Discussion
PBI Desktop / Unable to Change PBI Data Source SSAS Server Name
- Anonymous9 years ago
Hi Herbert,
The issue is not related to a specific machine but rather generic and I hope that it get addressed and solved by the BI team in a coming release...
The following workaround works:
* Create a dummy new report on PBI desktop connected to the new server. Save the report as DUMMY REPORT
* Open DUMMY REPORT in PBI Desktop
* Go to menu Open, and open the previously designed dashboard that was connected to the older server - Obviousy you will get the error that cannot open the report, but here you will get the dialog that contains the [Edit] button that allows you to change the server/database name. Change the server name and save the report
* Repeat the above 2 steps with the other dashboards...
Now all dashboards open correctly connected to the new server :smileyhappy:
Anonymous
It is strange that your PBI Desktop version is 2.41.4581.361 64-bit (January, 2016). The version number is from November, 2016. Have you upgraded your PBI Desktop to the latest version which is available here?
If you still have the same issue after upgrade to the latest version. I think you can try to rename a server/client name to the original SSAS name. Not need to be a real SSAS server, we just need to let PBI can find this old server name in the network. If we can open the PBIX file properly in this way, then we can change the data source.
You can also try to install the latest version of PBI Desktop in another machine and try to open this PBIX file to see if issue persists.
Best Regards,
Herbert