Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Jyothi_Suragani
Frequent Visitor

Not able connect to powerbi through blob storage connection using SAS Token

Jyothi_Suragani_0-1668586171281.png

I am trying to connect to Azure storage account using inbulit azure blob storage connection by providing SAS Token its throwing the Above error.I coudn't authenticate what can be the cause.

1 ACCEPTED SOLUTION
Anonymous
Not applicable

Hi @Jyothi_Suragani ,

This maybe a permission/authentication error. When you ever connect to  your data source in an unauthorized account, the corresponding credential would be created. You may need to change credential,  go to “File –> Options and Settings –> Data Source Settings”.

 

Please check the steps connect to powerbi through blob storage connection using sas.

  1. Navigate to powerbi.com.
  2. In your workspace, create a new Dataflow or Dataset.
  3. On the “Choose data source” page, search for your data source (ie. “Azure Data Lake Storage Gen 2” or “Azure Blobs”) and select a source.
  4. In the Authentication kind drop down, select the Shared Access Signature (SAS) option. To retrieve your SAS token, go to portal.azure.com, navigate to your resource, and, under Security + networking, select shared access signature and scroll down to view the SAS token. Paste the value into the box and select next.
  5. Proceed with the rest of the data transformation as usual!

More details: ADLS Gen2 and Azure Blobs SAS Key Connectivity | Microsoft Power BI Blog | Microsoft Power BI

Connecting to Blob Storage with a Shared Access Signature in Power BI | Microsoft Learn

 

If it still does not help, please provide more details.

 

Best Regards

Community Support Team _ Polly

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Anonymous
Not applicable

Hi @Jyothi_Suragani ,

This maybe a permission/authentication error. When you ever connect to  your data source in an unauthorized account, the corresponding credential would be created. You may need to change credential,  go to “File –> Options and Settings –> Data Source Settings”.

 

Please check the steps connect to powerbi through blob storage connection using sas.

  1. Navigate to powerbi.com.
  2. In your workspace, create a new Dataflow or Dataset.
  3. On the “Choose data source” page, search for your data source (ie. “Azure Data Lake Storage Gen 2” or “Azure Blobs”) and select a source.
  4. In the Authentication kind drop down, select the Shared Access Signature (SAS) option. To retrieve your SAS token, go to portal.azure.com, navigate to your resource, and, under Security + networking, select shared access signature and scroll down to view the SAS token. Paste the value into the box and select next.
  5. Proceed with the rest of the data transformation as usual!

More details: ADLS Gen2 and Azure Blobs SAS Key Connectivity | Microsoft Power BI Blog | Microsoft Power BI

Connecting to Blob Storage with a Shared Access Signature in Power BI | Microsoft Learn

 

If it still does not help, please provide more details.

 

Best Regards

Community Support Team _ Polly

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.