Forum Discussion
MySQL connection not working anymore: access denied
Hi all
We're using powerbi and report server at our organisation. We've got PowerBI October 2017 installed, but it happens on the most normal recent version as well.
When trying to connect to a MySQL database this error appears:
Details: "An error happened while reading data from the provider: 'Could not load file or assembly 'System.EnterpriseServices, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. Access is denied.'"
The enviroment is installed on Server 2016, it did work flawlessly in the beginning. No clue what happened in the meantime. Havent changed anything on the server, might be an update of windows?
I've tried the following but all attempts failed;
- Reinstall powerbi
- Reinstall MySQL Connector 6.6.5
- Install .NET Framework 4.7
- NetFXrepairtool
- Reboot server multiple times
- It works on other machines so its not caused by the databases itself
Nothing helps. It happens on all MySQL Server connections.
Please help,
14 Replies
- Greg_Deckler
Community Champion
Have you tried something like:
"C:\Program\Microsoft SDKs\Windows\v6.0A\bin\gacutil.exe" /i Microsoft.NET/Framework/v2.0.50727/System.EnterpriseServices.dll"
?
- dutchlimits
Helper I
Greg_Deckler Our server does not contain these directory's, what are you exactly trying to do with this?
By the way i forgot to say that the connection does work on other machines. But this is our PowerBI development enviroment so it must work on this server.