Forum Discussion

dutchlimits's avatar
dutchlimits
Icon for Helper I rankHelper I
8 years ago

MySQL connection not working anymore: access denied

Hi all

 

We're using powerbi and report server at our organisation. We've got PowerBI October 2017 installed, but it happens on the most normal recent version as well. 

 

When trying to connect to a MySQL database this error appears:

Details: "An error happened while reading data from the provider: 'Could not load file or assembly 'System.EnterpriseServices, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. Access is denied.'"

 

The enviroment is installed on Server 2016, it did work flawlessly in the beginning. No clue what happened in the meantime. Havent changed anything on the server, might be an update of windows? 

 

I've tried the following but all attempts failed;

  1. Reinstall powerbi
  2. Reinstall MySQL Connector 6.6.5
  3. Install .NET Framework 4.7
  4. NetFXrepairtool
  5. Reboot server multiple times
  6. It works on other machines so its not caused by the databases itself

Nothing helps. It happens on all MySQL Server connections. 

 

Please help, 

14 Replies