Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Anonymous
Not applicable

Measure results disappearing

Hello everybody!

I have a mesaure that calculate the percentage of level agreement ( revenue/comercial objective) for wich area, product etc. I call this measure GRO%.


When I creat a matrix only with areas/GRO, i have the right results: 
Area 1 | Objective 1200 | Revenue 1000 | GRO 83,33%

When I creat a matrix only with products/GRO, i have the right results: 
Product A | Objective 500 | Revenue 500| GRO 100,00%

 

I wanna see how each products is performing inside the areas. So I added the Product ID below the row of Area as a second level. However, when I did it the GRO% started to show wrongs values / or blank values. The values for Objective and Revunue keep right, only GRO% (revenue/objective) is wrong.

 

Could someone help me? 

 

Thanks!!!!

3 REPLIES 3
Anonymous
Not applicable

Hello, an example of the table:
Gray line = subtotals with level Products

Green line = Products > Stores

 

The problem is in the Var% measure: sometimes is right as figure 1, and sometimes is wrong, as 2nd:

1)

TonLima1990_2-1667927449693.png

2)

TonLima1990_1-1667927330694.png

 

Var% measure is 

 
Var%=
var aa = [Ano Anterior]
var realz = [Realizado]
var divd = ((realz-aa)/aa)
return divd

 

Any help?

 

Thanks, Antonio.

Shaurya
Memorable Member
Memorable Member

Hi @Anonymous,

 

Just check the measure that you have used for calculating GRO. It might be using some filter context or may be it has conditions that are filtering data.

 

If this doesn;t solve your problem, please provide some sample data and the calculations that you have used in the measure.

 

Mark this post as a solution if that works for you!
Consider taking a look at my blog: Forecast Period - Previous Forecasts

Anonymous
Not applicable

Thanks! I've checked all measure and there is no filter being applied. 
What is strange is:
Sometimes I expand the hierarchu (Area to Products) and get the right GRO results. But, if I collapse the hierarchy and expand it again .... I get wrong GRO values.

I don't know what is happening 😕

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors