Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Checklist
Advocate II
Advocate II

Maintain layer order does not work when published to service

Hi,

 

I noticed that the maitain layer order function does not work as expected anymore. Last time I checked it was working fine, but not anymore. 

Btw I am well aware that this function is only visible when published to service, however the published report acts now the same as the report in desktop version.  Has there been any changes / does anyone expierence the same issue ? 

 

I made a simple test:

Here are the layer order settings:

Checklist_0-1626160475686.png

I published it to service and clicked and hovered on the blue shape - the orange shape dissapears altough I have "maintain layer order" enabled - what is going on here? 

Checklist_3-1626160967463.png

 

 

 

1 ACCEPTED SOLUTION
v-eqin-msft
Community Support
Community Support

Hi @Checklist ,

 

The issue got resolved based on my test.

Please try again with the lateset version of Power BI Desktop.

 

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

11 REPLIES 11
Lisa_Rea_Dell
Regular Visitor

Is there a more recent thread on this?  My users are continuing to have these problems when we use a backsplash/water mark as the bottom-most image.  We're using Sep 2023 version of desktop publishing to the Service via Premium P2 license

lasersharks
Kudo Collector
Kudo Collector

I can also confirm I'm seeing the issue. Reports that were perfectly designed now have visuals jumping all over the place :(.

v-eqin-msft
Community Support
Community Support

Hi @Checklist ,

 

The issue got resolved based on my test.

Please try again with the lateset version of Power BI Desktop.

 

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

v-eqin-msft
Community Support
Community Support

Hi @Checklist ,

 

As I mentioned before, I have found it an internally reported issue , and I have shared the IcM ID.

So please stay tuned for fix.😀

 

Maintain Layer Order not working in PBI Service - Microsoft Power BI Community

 

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Sorry, I missed that. Thanks for the info. 

v-eqin-msft
Community Support
Community Support

Hi @rhernke ,

 

It's seems to be a known issue, the IcM ID is 250358593.

 

I will continue to pay attention to this issue, or you can use this ID to ask Microsoft staff about the progress of this issue .

 

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

v-eqin-msft
Community Support
Community Support

Hi @Checklist ,

 

I could not reproduce your issue, everything works on my side even if I disable the "maintain layer order" setting.

enable.PNG

 

disable.PNG

My desktop version is June 2021, you may try to upgrade your PBI to this version and have a try again.

June 2021 version.PNG

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I have the same problem, I only noticed when a user indicated it... I hope that with the July update this will be fixed. But even in Power service it doesn't work either.

Hi @v-eqin-msft ,

Thanks for the reply!
I have the latest version of Power Bi Desktop installed, but I am still experiencing the same problem. I published your pbix to My Workspace and the result is the same as I initially described. If I click and hover with cursor on the blue shape (Shape1), it comes in front of Shape2. I tried using Chrome and Edge - issue occurs with both browsers. Also, it seems that I am not the only one who is having troube with it. 

Checklist_1-1626337348230.png

 

Checklist_0-1626337316949.png

 

rhernke
Advocate I
Advocate I

We're seeing the same issue in our account as well. Reports that previously worked with maintain layer order are no longer working as expected and new reports do not work as expected with that functionality either.

Anonymous
Not applicable

@Checklist , yes i am seeing this problem as well , seems like a bug to me.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.