Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
hh26
Regular Visitor

Latest Update Creates Login Error

My PowerBI just updated automatically to the October 2023 option yesterday. Since then anyone at my organization is unable to sign in. We get the following error:

 

Unable to sign in

Sorry, we encountered an error while trying to sign you in. Details: Cound not load file or assembly

'Microsoft.IdentityModel.Abstractions, Version=6.22.0.0, Culture=neutral

Publickeytoken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest

definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

 

hh26_0-1697741243878.png

 

1 ACCEPTED SOLUTION
v-rzhou-msft
Community Support
Community Support

Hi @hh26 ,

 

This issue may be caused by rolling out the registry key
Hive: HKEY_LOCAL_MACHINE
Key path: SYSTEM\CurrentControlSet\Control\SecurityProvider s\SCHANNEL\Protocols\TLS 1.3\Client
Value name: Enabled
Value type: REG_DWORD
Value data: 0x1 (1)

Which is invalid for Windows 10 machines, since Windows 10 doesn't support TLS 1.3 according to docs at Protocols in TLS/SSL (Schannel SSP) - Win32 apps | Microsoft Learn
 
Removing the key or setting Enabled to 0 should fix the issue.
 

Best Regards,
Rico Zhou

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 
 
 

View solution in original post

13 REPLIES 13
BleepBloop
Frequent Visitor

We're impacted as well, unfortunately. We need to pull data from a 32-bit Access database, and therefore must use the 32-bit version of Power BI. I just downloaded the newly released version from Nov 1 and I'm still getting the same "Unable to sign in" error. Extremely frustrating!

v-rzhou-msft
Community Support
Community Support

Hi @hh26 ,

 

This issue may be caused by rolling out the registry key
Hive: HKEY_LOCAL_MACHINE
Key path: SYSTEM\CurrentControlSet\Control\SecurityProvider s\SCHANNEL\Protocols\TLS 1.3\Client
Value name: Enabled
Value type: REG_DWORD
Value data: 0x1 (1)

Which is invalid for Windows 10 machines, since Windows 10 doesn't support TLS 1.3 according to docs at Protocols in TLS/SSL (Schannel SSP) - Win32 apps | Microsoft Learn
 
Removing the key or setting Enabled to 0 should fix the issue.
 

Best Regards,
Rico Zhou

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 
 
 
mcclark
New Member

Apparently the incorrect Identity DLL version was installed with the October update (C:\Program Files (x86)\Microsoft Power BI Desktop\bin\Microsoft.IdentityModel.Abstractions.dll). You can try replacing the DLL with the older DLL version that PBI is referencing (Microsoft.IdentityModel.Abstractions, Version=6.22.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35) until the install file is updated. My best guess is that the incorrect DLL was referenced in the package as the 6.22.0.0 DLL is outdated and external PBI tools like tabular editor use later DLL versions...

hh26
Regular Visitor

I spoke with Microsoft support and resolved the issue by uninstalling and then reinstalling the version from the download center - Download Power BI Desktop from Official Microsoft Download Center. I am using the 64 bit version. 

rbrocks
Advocate IV
Advocate IV

We had a call with our support partner today. As of now, it appears that the versions installed from the web (not the microsoft store) is looking for a different version of a dll file than what is included in the download. We tried replacing the file with the version the error message indicated it is looking for and got yet another error. Our support partners are escalating the issue with Microsoft. I will update if I hear anything else back. It does seem to be both the 32 bit and 64 bit versions installed from the web. The 64 bit store version is working. Our users that need 32 bit version have reverted back to the September 2023 version as a workaround until the issue is resolved.  

v-rzhou-msft
Community Support
Community Support

Hi  @hh26 ,

 

According to your statement, I think your issue should be caused that your version is from App Store.

It will automaticlly update to a future beta, which causes it to be unstable.

Here I suggest you to removing this version from your local and then download the latest version from website.

Removing:

Solved: uninstalling Powe BI on Windows 10 - Microsoft Fabric Community

Download: Download

Also, you can checked with below options are Enabled.

Navigated to Options and Settings > Options > Security.

               -Checked the box for "Use my default web browser” and

               -“Use updated sign -in experience’.

vrzhoumsft_0-1698112212504.png 

 

Best Regards,
Rico Zhou

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

This doesn't resolve the issue for us Rico.

rbrocks
Advocate IV
Advocate IV

This is an issue for our users who have the 32-bit version of Power BI Desktop. They have to use this version for various reasons. In testing, using the store 64-bit version does take away the login error but it is not an option for most of the impacted users. This appears to be an issue with the 32-bit October 2023 version.

same problem... and I got no solution... I tried to change the options on security as the first comment suggested but it didnt work out.

 

Não foi possível entrar
Encontramos um erro ao tentar fazer o logon. Detalhes: Não foi possível carregar arquivo ou assembly 'Microsoft.IdentityModel.Abstractions, Version=6.22.0.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35' ou uma de suas dependências. A definição do manifesto do assembly localizado não corresponde à referência do assembly. (Exceção de HRESULT: 0x80131040)

Reverting back to the September 2023 32-bit version worked for our users as a workaround until this is resolved.

mveres
New Member

Hello, one of my users is experiencing the same issue.

 

Any fixes yet?

Braziluser
New Member

I'm with the same problem. I just download the latest version and came up with the same error:

 

"Encontramos um erro ao tentar fazer o logon. Não foi possível carregar arquivo ou assembly 'Microsoft.IdentityModel.Abstractions, Version=6.22.0.0, Culture=neutral, PublicKeyToken=31bf385ad364e35' ou uma das suas dependências. A definição do manifesto do assembly localizado não corresponde à referência do assembly (Execução do HRESULT: 0x80131040)"

 

Braziluser_0-1697828587974.png

 

Idrissshatila
Super User
Super User

Hello @hh26 ,

 

you could report it directly to microsoft support through this link https://support.powerbi.com

 

If I answered your question, please mark my post as solution, Appreciate your Kudos 👍

Follow me on Linkedin
Vote for my Community Mobile App Idea 💡



Did I answer your question? Mark my post as a solution! Appreciate your Kudos
Follow me on LinkedIn linkedIn
Vote for my Community Mobile App Idea

Proud to be a Super User!




Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.