Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

New Member

Google Analytics Access to resource is forbidden

Has anyone started to see this error?  No issues last week pulling Google Analytics data in Power BI Desktop but suddenly started getting resource is forbidden.  A note I can login with no issues to Google Analytics platform.




Helper I
Helper I

Hi all,

Have you all find the solution to this issue? I'm facing the same issue just today. Last night everything was working just fine. Super irritated.

Kindly help if can. Thanks!

Helper III
Helper III

Anyone facing the issue again as well?

Hi, Ask your GA admin, if is not you, to grant your permission again. That works for me. Daniel

Frequent Visitor

Apparently there is an update on the GA permissions that the admin user need to go through, so you can access again using Power BI.



I have the same problem. Don't know how to fix it...

i've accessed the google analtics but didnt see anything that need to provide further permission. Still having the forbidden error message

New Member

I am also getting this error. I tried to clear permissions and then reset them and it still didn't work. 

Frequent Visitor

Having same issues here. "Access to resource is forbidden"

Regular Visitor

ditto here - queries from Google Analytics which were running fine before now all return "Access to the resource is forbidden."

This was a temporary issue and got fixed automatically 🙂

We have the same problem, when was it fixed?

Frequent Visitor

I am getting this error starting from this morning.Anyone facing the same?

Same, I am having the issue. 
Hope is temperory only.

Morning it was working fine. Suddenly it stopped working and throwing this error.

Tried clearing the cache and clear permissions. Still not working 😞

New Member

I've also opened a support case and will let everyone know what i hear back

Hi all,


There's an issue on our side with the connection to Google API. It should be resolved now.

It started working again this morning.  Do we know what caused this issue?

Regular Visitor

Yeah. I'm getting the same 'Access to the resource is forbidden' message as well. Like another poster said, hopefully just temporary. 

Regular Visitor

Yes, I started seeing this today where 2 days ago it was fine with no change.

I can credential into Google Analytics fine - both in Power BI as well as at


I've cleared my Power BI cache as well as generated the corresponding logs which seem to point to this error:


DataMashup.Trace Warning: 24579 : {"Start":"2016-05-04T18:49:36.4217898Z","Action":"Library/Common/RetryPolicy/TryExecuteAction","Attempt":"1","Exception":"Exception:\r\nExceptionType: System.Net.WebException, System, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089\r\nMessage: The remote server returned an error: (403) Forbidden.\r\nStackTrace:\n at System.Net.HttpWebRequest.GetResponse()\r\n at Microsoft.Mashup.Engine1.Library.Web.Request.CreateResponse(ResourceCredentialCollection credentials)\r\n at Microsoft.Mashup.Engine1.Library.Web.Request.GetResponseCore(ResourceCredentialCollection credentials)\r\n at Microsoft.Mashup.Engine1.Library.Common.RetryPolicy.Execute[TResult](IEngineHost host, Func`1 func)\r\n\r\n\r\n","ProductVersion":"2.34.4372.322 (PBIDesktop)","ActivityId":"f0d75a43-a659-4fe5-8fd2-288f39643b6e","Process":"Microsoft.Mashup.Container.NetFX40","Pid":23668,"Tid":1,"Duration":"00:00:00.7919753"}


DataMashup.Trace Error: 24579 : {"Start":"2016-05-04T18:49:36.4216208Z","Action":"Library/Common/RetryPolicy/ExecuteAction","TryCount":"3","RetryAlgorithm":"ExponentialBackoff","Exception":"Exception:\r\nExceptionType: Microsoft.Mashup.Engine.Interface.ResourceAccessForbiddenException, Microsoft.MashupEngine, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35\r\nMessage: Exception of type 'Microsoft.Mashup.Engine.Interface.ResourceAccessForbiddenException' was thrown.\r\nStackTrace:\n at Microsoft.Mashup.Engine1.Library.GoogleAnalytics.GoogleAnalyticsRequestPolicy.ShouldRetry(Exception e)\r\n at Microsoft.Mashup.Engine1.Library.Common.RetryPolicy.Execute[TResult](IEngineHost host, Func`1 func)\r\n\r\n\r\n","ProductVersion":"2.34.4372.322 (PBIDesktop)","ActivityId":"f0d75a43-a659-4fe5-8fd2-288f39643b6e","Process":"Microsoft.Mashup.Container.NetFX40","Pid":23668,"Tid":1,"Duration":"00:00:00.7926681"}



Anyone else run into this error?

For what it's worth, I'm getting the error too.


Screen Shot 2016-05-04 at 3.16.47 PM.png

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.