Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
Anonymous
Not applicable

Format with "." as thousand separator and "," for decimals

Hi,

 

I'm living in Denmark wher we use "." as thousand separator. When i use

 

format(MEASURE, "#,##0")
 
i get a thousand separator with ",". 
 
How can i convert this to "."?
 
Best regards
1 ACCEPTED SOLUTION

HI @Anonymous,

You can try to use custom formatting string on your formula to modify the displayed format:

Use custom format strings in Power BI Desktop - Power BI | Microsoft Learn

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

View solution in original post

3 REPLIES 3
ribisht17
Super User
Super User

Hi @Anonymous 

 

Refer > https://community.fabric.microsoft.com/t5/Desktop/Thousand-Separator-and-Decimal-Separator/m-p/194928

 

The display of numeric felds (and dates, times etecetera) depends on your Regional Settings.

 

It can be adjusted in Power BI Desktop or in Windows (Land/Region). It looks like the Windows setting is leading, but you have to close and reopen your pbix file after adjusting the Regional Settings.

 

ribisht17_0-1704361336459.png

 

 

In Power BI you can also adjust your language settings to influence the display format for published reports.

 

Regards,

Ritesh

Mark my post as a solution if it helped you| Munde and Kudis (Ladies and Gentlemen) I like your Kudos!! !!
My YT Channel Dancing With Data !! Connect on Linkedin !! PL 300 Certification Series

Anonymous
Not applicable

Thanks for the reply. 

I already have my settings in danish. The problem occurs because I have made a measure which returns a string.:

Kioskkunder faktisk og budget =
var faktisk = [Kioskkunder]/1000
var budget = [Kioskkunder budget] /1000
return
format(faktisk, "#,##0") & " | " & format(budget,  "#,##0")

How do i, in the format function, alter to the correct format? 

HI @Anonymous,

You can try to use custom formatting string on your formula to modify the displayed format:

Use custom format strings in Power BI Desktop - Power BI | Microsoft Learn

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

March 2024 PBI Gallery Image

Power BI Monthly Update - March 2024

Check out the March 2024 Power BI update to learn about new features.