Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Regular Visitor

Export to PDF not Exprting to correct Size



    When I am Exporting to PDF via the Desktop, I have selected the Letter page size, the PDD shows it is as an 8 1/2 X 11. But when it populates, there are about 1 in Gaps at the Top, Right, and bottom Margins. When you look at the desktop version, it looks perfectly fine.  Any suggestions?DesktopDesktopPDFPDF

New Member

Update WebView2 to 118.0.2088.76, it's work for me

Regular Visitor

Only one way how to export to PDF that I found is => publish power BI to my working area, and from this area I can export to PDF in a properly size

I guess this topic comes up through google, which is not the same orignal issue; There is a topic specific for this issue caused on 10/23/2023:

Export to PDF doesnt work with page size anymore - Microsoft Fabric Community

Frequent Visitor

I was able to fix the issue by selecting View > Page View > "Fit to Actual Size" (or one of the other options may work).

Also, resetting the page information. e.g. I had my page originally set to 16:9, and I changed it to Custom, then back to 16:9.

Thankyou. Fir to actual size really helped 🙂

Not working in version 2.121.903.0 64-bit (September 2023). For some strange reason, the export has stopped working. It had worked for a long time, even with this version. Maybe there is a problem in Windows 10 and 11?

The export to pdf feature worked for me up until last Thursday (10/19/2023).  I have no idea why it stopped working properly.  It seems like there is a page sizing issue when it exports.  Only a portion of the page appears to export and it seems as though it is zoomed in on just that portion of the page.  

I have the same issue since this week.

Have the same exact issue with resize and export containing only left corner of the report. Did anyone find workaround?

Hi. Only one way , that I found - to publish your desktop report to workspace and from there you can export in a properly size 

I'm having the same issue.  I printed a simple, one page report last week and that same report appears "zoomed in" after export.  Is the .pdf output focused only on the top left corner of your report as well?

Also experiencing this issue, guessing some type of update was rolled out on thursday or friday. Was hoping there would be some information in the change log but there doesnt seem to be anything. 

Left PC at work and now we are having this same issue on a Monday. Any suggestions would be great. 

I am currently using the snipping tool and pasting the images into a word doc and then goin to print to .pdf   VERY time consuming...

This is def a bug. The issue is when you have your Page view setting set to "Fit to Page", and click export to PDF, it automatically changes page view setting to "Actual Size" when the export begins. 

New Member

This worked for me most of the time.  Before exporting to pdf, try View--> Fit to Page.  Then File--> Export to PDF.  

Community Support
Community Support

Hi @whatlje1 

I can reproduce your problem.

Based on my understanding, the Gaps are the default gaps in a pdf file, like when we open a word file, there are already gaps.


Anyhow, i will check with Product team whether this is a bug or not.


Best Regards


Community Support Team _ Maggie Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Not applicable

Hello any news on this issue?

I haven't had to update my reports until recently, and now it just so happens that all of them are unreadable because of scaling issues.

I've tried all of the solutions/workarounds i could find online (including the ones in this thread) but none have worked for me so far.


Would really appreciate any feedback on this issue.




Not applicable

Hello @whatlje1 


Make sure you have the filter pane collapsed when you export the PDF, I had to do that in order to get rid of awful, large white spaces in the top, right, and bottom areas of my PDF exports.


Another thing that may help somewhat is to completely disable the "updated filter pane" - File -> Options and Settings -> Options -> Current File \ Report settings



Disable Updated Filter Pane.png


I found this to be a requirement in order to avoid larger white space on the right side of my exported PDF files than on the left side--this seems to be an issue that was created in the May 2019 release (v. 2.69.5467.1751) because reverting back to the April 2019 release did not produce this issue.


Ultimately, I don't know how to approach the basic question you have asked because I have been unable to export a normal 8.5" x 11" PDF in Power BI Desktop, they always come out sized 9.5" x 12". I have been able to achieve an 8.5" x 11" PDF by taking the export and then printing to PDF, but that creates its own set of issues and, in my opinion, should never be necessary since the standard "Letter" size should be the actual size of a piece of paper.


@v-juanli-msft  No matter how you look at it, *something* is wrong here. I just want to be able to export a PDF in the normal size, this shouldn't be so hard.

I was able to Colapse the Filter Pane and export it with less margins on the sides. For now, That is a good work around.

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.


Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors