Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
marapdq1993
Frequent Visitor

Exclude a single field from a drillthrough filter

Hello,

I have set up a drillthrough functionality in my powerbi report. The source visual is a stacked bar chart with the attributes on the y-axis with the Value field as the legend (e.g. Very Poor, Poor, Good, Very Good). Values are based on count of respondents. 

 

See sample below for the source visual.

 

Source visualSource visual

 

In the drillthrough page, I added the attribute under the drillthrough filters. This is how it looks like in my report. 

 

Value screenshot.png

 

I want to be able to exclude the value field in the drillthrough so I can achieve something like the screenshot below in the drillthrough page. I tried to create a measure -> 

CALCULATE(COUNT([ID]), ALL('Table1'[Value])) but it doesn't seem to work. And just returns a single value instead of a stacked bar 😞 Is there a way to exclude the Value field?

 

drillthrough visual.png

 

Thank you. 

5 REPLIES 5
v-jayw-msft
Community Support
Community Support

Hi @marapdq1993 ,

 

On drill through page, disable 'Keep all filters', then remove the columns you want to exclude from drill through filter.

 

Best Regards,

Jay

Community Support Team _ Jay
If this post helps, then please consider Accept it as the solution
to help the other members find it.
amitchandak
Super User
Super User

@marapdq1993 , disable keep all filter, Then it will on pass values, which are given below in - Add drill through parameters here

Hello @amitchandak ,

Have I done it correctly? I disabled the keep all filter and added the other filters but it doesn't seem to work.

updated.png

 

Not sure if this will help but the other drillthrough fields are coming from a different data source and I just created a relationship with the survey responses data

@marapdq1993 , The one you want to exclude (do not want to pass in drill), should not be there in the list

Hi @amitchandak ,

I removed the Value field in the list but it always comes back whenever I drill through again. Will try if I can send a quick video. Thanks!

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.