Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Advocate I
Advocate I

Error when publishing a report from despktop



I am trying to publish a report, from PowerBi Desktop, to display them online on dashboards.

It seems that no matter what I do, it keeps on handing me an error saying "Unexpected error - The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel".


The error changed shortly to some error regarding a Unexpected JSON.

I then tried publishing another report, but I still got the same error. Both reports have been published before.



Frequent Visitor

Same issue, sent a frown and details.

RESOLVED. By itself when I tried again this morning. I think Microsoft side were having some certificate issues last night. They might have rectified it as it worked again today. I sent a frown as well last night but did not receive a reply yet so frowning is not really that fast as they claimed. 🙂

Helper III
Helper III

Same Issue here.  Did not have any issues with publishing yesterday and now I can't publish at all. Please help I have a demo to give this Friday !!

New Member

same error here...

any solution ??

Seeing same thing. Just posted about this in Service forum. Should have looked here first.


Seems obvious from the numbers of folks posting about this that MSFT have an issue on the service side.

Make sure you submit this as a bug report, as well. You can do so in PBI Desktop by using the 'Send a frown' option in the File menu, and using the feedback menu in PBI Service.

The forums are a great avenue for discussing issues, sharing thoughts / ideas, and troubleshooting, but they are not the official medium to submit bug reports.

Proper bug reports will receive more attention from the devs than forum posts.

New Member

I have the same issue. Tried different networks no go. Never had the problem yesterday.

Advocate I
Advocate I

Not sure of the underlying issue but was getting the same error this morning.  A workaround to publish my reports was to;


  • Log onto to the Website;
  • Click 'Get Data';
  • Select 'Import' - 'Files';
  • Browse to your local version of the .pbix file;

From this point worked as per normal process.



New Member

I am getting the exact same error. It does not seem to be related to a specifit data source - every report I ahve tried to upload encounters the same issue.

Helpful resources

Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.


Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors