Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Anonymous
Not applicable

ERROR loading Slope Chart by MAQ Software

Trying to use the Slope Chart get the following

 

Feedback Type:
Frown (Error)

Timestamp:
2018-02-12T15:55:03.5660991Z

Local Time:
2018-02-12T07:55:03.5660991-08:00

Session ID:
9d7dcd7c-b2b1-466d-b1aa-c9077fc5a62d

Release:
February 2018

Product Version:
2.55.5010.621 (PBIDesktop) (x64)

Error Message:
R script error.
Loading required package: XML
Warning message:
package 'XML' was built under R version 3.4.1
Loading required package: htmlwidgets
Warning message:
package 'htmlwidgets' was built under R version 3.4.3
Loading required package: ggplot2
Error in inDL(x, as.logical(local), as.logical(now), ...) :
  unable to load shared object 'C:/Users/<USER>/Library/rlang/libs/x64/rlang.dll':
  LoadLibrary failure:  The specified procedure could not be found.

In addition: Warning message:
package 'ggplot2' was built under R version 3.4.3
Warning message:
In libraryRequireInstall("ggplot2") :
  *** The package: 'ggplot2' was not installed ***
Loading required package: plotly
Loading required package: ggplot2
Error in inDL(x, as.logical(local), as.logical(now), ...) :
  unable to load shared object 'C:/Users/<USER>/Library/rlang/libs/x64/rlang.dll':
  LoadLibrary failure:  The specified procedure could not be found.

In addition: Warning messages:
1: package 'plotly' was built under R version 3.4.3
2: package 'ggplot2' was built under R version 3.4.3
Failed with error:  'package 'ggplot2' could not be loaded'
Warning message:
In libraryRequireInstall("plotly") :
  *** The package: 'plotly' was not installed ***
Loading required package: magrittr
Warning message:
package 'magrittr' was built under R version 3.4.3
Error in eval(expr, envir, enclos) : could not find function "plot_ly"
Calls: tryCatch ... tryCatchList -> tryCatchOne -> <Anonymous> -> %>% -> eval -> eval
In addition: Warning message:
In plot_ly() %>% layout(title = "", xaxis = xLayout, yaxis = yLayout) :
  bytecode version mismatch; using eval
Execution halted

 

1 ACCEPTED SOLUTION
MAQSupport
Solution Supplier
Solution Supplier

Hello @Anonymous,

 

Please ensure that you have the latest version of Power BI installed on your system.

On downloading the sample file, you should be getting a prompt message box as shown below.

Click ‘Install’ button on the message box. It will install required packages automatically.

 

 

slope.png

 

If the message is not visible, please install the required R packages by running the below commands in RStudio or any other R tool installed on your machine:

install.packages("ggplot2")

install.packages("plotly")

install.packages("scales")

install.packages("htmlwidgets")

install.packages("XML")

install.packages("ggrepel")

 

After installing above packages, the visual will work fine on your system. 

 

Please get back to us, in case the issue still persists. We can be reached at support@maqsoftware.com

 

Thanks!!

View solution in original post

3 REPLIES 3
MAQSupport
Solution Supplier
Solution Supplier

Hello @Anonymous,

 

Please ensure that you have the latest version of Power BI installed on your system.

On downloading the sample file, you should be getting a prompt message box as shown below.

Click ‘Install’ button on the message box. It will install required packages automatically.

 

 

slope.png

 

If the message is not visible, please install the required R packages by running the below commands in RStudio or any other R tool installed on your machine:

install.packages("ggplot2")

install.packages("plotly")

install.packages("scales")

install.packages("htmlwidgets")

install.packages("XML")

install.packages("ggrepel")

 

After installing above packages, the visual will work fine on your system. 

 

Please get back to us, in case the issue still persists. We can be reached at support@maqsoftware.com

 

Thanks!!

Anonymous
Not applicable

Thanks for the support

 

For some reason the Packages wouldl not Install - so I had to Unistall and reinistall R! but that got it

v-qiuyu-msft
Community Support
Community Support

Hi @Anonymous,

 

Slope Chart by MAQ Software is a custom visual built with R. If you open this custom visual in Power BI Desktop, you may need to install additional R packages and/or an R engine. From the error message, it seems you need to install package plotly and ggplot2. 

 

As this is a customer visual, I would suggest you contact the author via Support@MAQSoftware.com.

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors