Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
gobrien06
Frequent Visitor

Dollar Sign Not Showing on Legend for Currency

Hi, 

 

I have a visual of Tickets Sold by Price Point, with Tickets Sold on the Y-Axis, and Price as the legend. The Price column is defined as currency, however, the Price Legend does not have a $ next to the Price Values. 

Screenshot 2023-04-11 092554.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

I have another visual of Tickets Sold by Price and Month, in the same layout as the previous graph, with the addition of Month on the X-Axis. In this visual, the $ does show with the Price Values. 

Screenshot 2023-04-11 092610.png

 

 

 

 

 

 

 

 

 

 

 

 

 

How do I get the $ to show in the legend of the first graph? It does not appear to be associated with a setting, as I can start with the second graph that has the $, remove month from the X-Axis, and suddendly the $ disappears from the legend. 

 

Thanks. 

1 ACCEPTED SOLUTION

@amitchandak I tried moving Price to different fields, however that did not resolve the issue. I was able to figure out a work around... 

 

If I add "Day" as the X Axis, it adds the $ to Price. Because of the structure of my data, all dates are on the 1st of the month. So, adding Day as the X Axis did not change the appearance of the visual at all. I was then able to turn off the X Axis so the graph appears just as I wanted. 

 

View solution in original post

3 REPLIES 3
DOLEARY85
Super User
Super User

Hi,

 

I've been testing and it seems like if you remove it from the legend and re-add it it should work. Also moving it to and from another area of the chart can cause it to reappear. 

amitchandak
Super User
Super User

@gobrien06 , Tried out. The behavior was not fixed. It was not showing for the first time. Then I moved it to axis and back to the legend and it start showing. and post that it was showing in a new visual where I directly add that as a legend

@amitchandak I tried moving Price to different fields, however that did not resolve the issue. I was able to figure out a work around... 

 

If I add "Day" as the X Axis, it adds the $ to Price. Because of the structure of my data, all dates are on the 1st of the month. So, adding Day as the X Axis did not change the appearance of the visual at all. I was then able to turn off the X Axis so the graph appears just as I wanted. 

 

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.