Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
vanessa
Post Patron
Post Patron

Disable drillthrough for few visuals

Is there a way to disable the drillthrough functionality for a visual on a report which contains the drillthrough column?

1 ACCEPTED SOLUTION

@v-yuezhe-msft

I used a workaround. I created a duplicate column and used that in the visual.

View solution in original post

12 REPLIES 12
daniel_baciu
Helper I
Helper I
bmk
Helper II
Helper II

Is this approach still the only solution since 2018? If yes, this is quite inefficient. There should be a simple straightforward option to disable drill throughs for specific visuals.

Anonymous
Not applicable

Hello all, I had the same issue, after I added some tooltips I had the option to Drillthrough - i did not need that so i followed the suggestions here - i changed the name for one of the columns i used in the tooltip. The one specific though whas that i changed the name only for the specific visual - i have no idea if this is a new feature or not but this was a life saver. 

Anonymous
Not applicable

I have same issue. Duplicating the column is not working as well as its filtered already. So, I duplicated the table and kept is without a connection to make it work.  For now, this is working for me.

v-yuezhe-msft
Employee
Employee

@vanessa,

I haven't found any methods that can be used to disable drillthrough functionality for visuals unless you remove the drillthrough column from the visuals.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-yuezhe-msft

I used a workaround. I created a duplicate column and used that in the visual.

Great reply and it was so powerful, thanks for the advice!

Could you please explain this more detailed ?

@josipinho 

 

I have a bar graph which is showing the year wise sales. I have enabled drill through on the Year column (i.e. Year column is added to the drillthrough filters field), hence by default this graph will have an option to drill-through.

 

In order to disable this, I duplicated the Year column (this can be done in the Edit Queries window) in the same table as Year and renamed it to Year_Copy and replaced Year column in the bar graph with this new column.

 

Since Year column is used in the drillthrough filters field and the bar graph has Year_Copy, the drill-through is disabled.

 

Hope this was helpful.

Anonymous
Not applicable

Hi,

 

I have tried with this method of you, when i came in drill through option , fact table content is filterd by the the month and how it is possible to discard that fileter in the context when having same field duplicated , in my case that is not working.

I am trying to do the similar thing. Its not working for me as the table is already filtered by the Year Column. How to avoid this.

Yep I figured it out yesterday after seeing your post 🙂 Thanks for the explanation 

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors