Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Made0n
New Member

Details: "Unable to find the requested .Net Framework Data Provider. It may not be installed."

I am trying to connect to MS SQL Server. Getting this error:

Details: "Unable to find the requested .Net Framework Data Provider.  It may not be installed."

 

Googled. No luck.

9 REPLIES 9
Matthieu2512
Frequent Visitor

I have a simular problem.  I used to be able to connect to Tera data from power BI.  On my old laptop everything worked. After reinstalling Tera Data, Power BI, The .net provider en LDAP on my new laptop I am unable to connect to Tera data. I have installed the latest version of the .netprovider but am unable to connect. (Have reinstalled several times)  Error states: One or more parts  have to be installed before this connector can be used.

 

My machine config looks like this in the framework 64  v2.0.50727

Matthieu2512_0-1630401087509.png

 

leonardmurphy
Skilled Sharer
Skilled Sharer

Where are you trying to connect from? The Power BI desktop app? Do you mind sharing the exact steps you're taking?

---
In Wisconsin? Join the Madison Power BI User Group.

I'm experience exactly the same problem. I've just installed Power BI Desktop.

I found a solution: in my case the machine config has a duplicated entry "DbProviderFactories". As soon as I deleted one of them and restarted PowerBi, it started to work.

 

 Hi there,

 

I am having the same problem (error message partly in german, but it reads the same), unfortunately the adivce regarding DbProviderFactories did not work.

2016-04-26 15_52_57-.png

 

I found references of machine.config in the following four places

 

#1 C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG\machine.config

#2 C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config\machine.config

#3 C:\Windows\Microsoft.NET\Framework64\v2.0.50727\CONFIG\machine.config

#4 C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config

 

I am new at this but #2 and #4 seem to be odd, going in the direction as to say "duplicate <DbProviderFactories> entry" as Romoreira suggests.

 

This what it looked like.

2016-04-26 15_57_33-_C__Windows_Microsoft.NET_Framework64_v4.0.30319_Config_machine.config - Notepad.png

 

This is what i now looks like, uncommented that thing.

2016-04-26 15_57_58-_C__Windows_Microsoft.NET_Framework64_v4.0.30319_Config_machine.config - Notepad.png

I restarted the PC, refreshed my pbix file, dragged some field on the report and still get the same error message.

I do have to day: I am using DirectQuery on the Oracle Database, the previews in PowerQuery load fine, its only when i drag and drop fields onto the report that I get this error. When I change from DirectQuery mode to Import mode, I do not get this error.

 

I also read somewhere that maybe installing "ODAC" (oracle data access components) from Oracle, but I am hesitant to do so since this is a work PC.

 

So does this directly relate to DirectQuery? Connecting to the Database in Power BI using ImportMode works fine.

 

Here's the source:

 

https://social.technet.microsoft.com/Forums/en-US/c06b9b93-fb55-4147-8d8b-0e613f9949fc/errors-in-the...

 

http://www.oracle.com/technetwork/topics/dotnet/utilsoft-086879.html

 

This is what solved it for us:
In the case with direct query towards an Oracle database this is what solved above error message for us:

  • Install Oracle Client 12.1 (64-bit ODAC 12c Release 4 (12.1.0.2.4) for Windows x64) as an additional Oracle home on your gateway server (we were running 12.2)
  • Restart you On-premises data gateway (it did not work if you didn't restart the gateway)

Seems as Oracle 12.2 for some reason doesn't work with direct query.

This solved the issue for me. Thanks a bunch!

...and if you run into the issue from Power BI desktop - installing above mentioned version of Oracle on the computer/server running PBI Desktop fixes the issue.

asad
Frequent Visitor

Did you get a solution to this?

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.