Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Regular Visitor

Default Page of a Report

Hi All,


First time here, I've searched through the existing questions but cant find anything that solves my problem (this question is the most alike and I tried it but still the same) -


I have a requirement from a client that would like to see page 1 by default on a multi page report. At the moment, when you click on the report, it loads as page 2. I know it's a very small thing but is there a way to set a default page when opening a report, or is it something I haven't done right in the set up?


Any help is much appreciated, thanks!

New Member

From the page where you publish your report, that is your default page. 

Example: If your report has 3 pages, you click on publish from page 2. Then page 2 is your default page.


Hope this helps.

Helper I
Helper I

Open the Power BI dashboard in the workspace where you published it. Go to the page you want to set as the default page. Click "File" > "Embed Report", then select the proper option then copy the URL and replace your old one on Portal/SharePoint Online ... Basically you have to go through the steps share your dashboard again.

Advocate I
Advocate I


I got the same issue, but solved it. Please try this way.

1. Go to your workspace which including that multi-page report.

2. Go to Report tab

3. Open your report.

4. On the top bar, click "Edit Report".

5. Go to the page 1 or any page what you want to be shown on next time you open it.

6. Go to the Top bar menu, choose Save.

7. Done. Try it.


This does not work for me in power bi service with a publisheed report.

Thank you!
Helper I
Helper I



I found that the page you are on is set as the default page when the report is publish.So try this. Save a copy of the report and publish it when you are on the page that you want to be the default opening page (landing page).


Hope this works,



Frequent Visitor

I had the same issue then I remembered that I have made changes to page size for my main page that’s I could not make it default.


So to fix this I made my other page smaller in page size compare to my default page and then went to default page and deployed the report since then works fine for me.


Did I answer your question? Mark my post as a solution!

Frequent Visitor

You just need save your report, from the page which you want to have it as home page or landing page


Community Support
Community Support



Based on test, I have find any options to set the default page, perhaps you can post this requirement to ideas. (the solution which you mentioned also not works for me)



Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

You have to save the Power BI report on the same page which you want to use as a default page and publish it, if the Power BI report is already published then login to the Power BI website and delete the report from the website and publish it again with the selected default page. This should work, it worked for me.

Changing the page to the default page seems not to be enough when you didn't make anyother changes.

Therefor you should make a minor change (like adding a textbox), save it, remove textbox, save it, make sure the tab is on the default page, upload report to power bi.


This works for me. This workaround is not optimal, I think Microsoft should add a feature to set the default page for a report.

@Marc1979 , thank you. This solution worked for me!

If i use a ifram to embed a report on html, can i set a filter on the embed src to go specifically to a page as start? irrelevant on what page the report is opening when i logging to powerbi?

Agree. I have a same request to add one page as default today.

Community Champion
Community Champion



I think if you save the report in the page 1, when you open it show page 1.

Lima - Peru

Hi @Vvelarde ,


Thanks for the message, I already tried this, still takes me back to the other page when I go to the report online.



Community Champion
Community Champion

Are you clicking on the report in the list of reports on the left side of the screen, or are you clicking on an element in a dashboard?

Did I answer your question? Mark my post as a solution!

Proud to be a Super User!

Clicking on the report on the left hand side of powerBI web

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.