Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
H3nning
Resolver I
Resolver I

Date range sclicer on today

Hi,

 

I have have a problem with a date slicer,but not in list form. I found workarounds for date lists, but i want to have the range slicer:

H3nning_0-1673599506268.png

 

In my date table I have a column [FutureDate] which is filtered out here. I use this because in my dashboards the actual date is always yesterday. With this, the latest selectable value of the slicer gets updated every day to the correct value (yesterday). The problem is, that this value is not actually selected. The actual selection remains on the value I have selected while uploading and to have it always on latest date i would have to re-publish it every day just with the slicer set to max. 

Is there a way to set the selected value of the slicer always on max?

 

Thanks and best regards!

1 ACCEPTED SOLUTION
VVR
Frequent Visitor

Does it help if you remove your Date-field from slicer’s field and then plug it back to the field? If you then publish your application without “touching” date values in the slicer it may work. Otherwise, there will be some fixed date range selected by default (I guess…).

View solution in original post

7 REPLIES 7
VVR
Frequent Visitor

Does it help if you remove your Date-field from slicer’s field and then plug it back to the field? If you then publish your application without “touching” date values in the slicer it may work. Otherwise, there will be some fixed date range selected by default (I guess…).

sometimes its so easy... Thanks!

VVR
Frequent Visitor

I have a same or similar kind of situation. Several applications have previously worked fine so that if I selected the maximum available date value to the slicer at the time of publication then next day after scheduled data refresh the selected maximum date (end value in the slicer) has updated according to the new available data. Now all new publications that I have recently made aren’t anymore working like this and the slicer is stuck in the original position (even if the pbix file is exactly the same as previously). Maybe this is the result of December 2022 release?

Hello @H3nning 

 

I just came across this solution, you will just have to check edit interaction for this particular slicer and if it is active just select filter.  

let me know if this helps !

Hi, thank you. Can you elaborate? What do you mean by edit interactions is active. Of course this slicer has interactions, otherwise it would have no function.

And what is select filter? Could you maybe post a screen which button you mean?

JadhavVarsha_13_0-1673874952107.png

If you select and check edit interaction option on the between slicer, you will find that it is active to disble that you will just have to click on that filter option.

Help this works

I don't have any visual that filters the between slicer. So that cannot be the reason. But thanks anyway 🙂

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.