Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
dd88
Resolver I
Resolver I

Date format is text and displays as AUS format ddmmyyyy uploaded online is in US format mmddyyyy

A column NextReviewDate is formatted as Date, a new column is copied NextReviewDate - FieldAsText, and the format is Text. the reason is to display a 'clean date', ie no time, and no financial quarter break down.
If there is a better format way please let me know.

 

In PowerBI desktop, in the visual table I added the column NextReviewDate - FieldAsText.
The results for  NextReviewDate - FieldAsText
The date displays correct in Australian format ddmmyyyyy

The device is set to local AUS date format

 

DatesDisplay - in PowerBI desktop  -Correct Australian format ddmmyyyy - 01.png

 

I uploaded the report online. Tested and the Next Review Date displays in correct AUS format ddmmyyyy

 

DatesDisplay - on web Correct Australian format ddmmyyyy - 02.png

 

 

I had to build in new report updates.
Tested in PowerBI desktop, displays in correct AUS format ddmmyyyy
I uploaded the report online, and tested. now the date displays in US format mmddyyyy

 

DatesDisplay - on web incorrect date format ddmmyyyy - 03.png

 

 

The report audience is the Executive team, and I would like to ensure the data presents correctly. before I release the report.

 

How can I resolve this to display the correct format as ddmmyyyy and its simple, and not write an essay, or complex code to resolve the date format and the date format to  'stick' ie one day it displays correctly, a different day date format is changed
Another thing, this field is formatted as Text. how is this recognised as date, and set date format as US format

 

TIA

3 REPLIES 3
v-rongtiep-msft
Community Support
Community Support

Hi  @Shravan133 ,

Thannks for the quick response.

 

Hi  @dd88  , 

I have some information to add.

1.Make sure that the format of your Short date is DD/MM/YYYY , because the date format decides the date format of your client .

 

2.In Desktop options , choose the Windows default display language in Global Regional Settings and English(Australia) in Current file Regional Settings (After changing ,you need to restart your Power BI Desktop) .

1.png2.png

 

 

3.In your Data view , change the Data type of your date to DD/MM/YYYY .

 
 
 

I have also found a similar post, please refer to see if it helps you.

Solved: Date format DD/MM/YYYY (Australia) in published Po... - Microsoft Fabric Community

 

How to Get Your Question Answered Quickly - Microsoft Fabric Community

 

If it does not help, please provide more details with your desired output and pbix file without privacy information (or some sample data) .

 

Best Regards
Community Support Team _ Rongtie

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

 

 

 

 

 

 

Shravan133
Resolver II
Resolver II

Change your browser language setting to the desired locale.

Shravan133_0-1717127387101.png

This should fix your problem.

 

Cheers

Thank you @Shravan133 

 

Each browser, Edge & Chrome language are already configured to Preferred Language = English (Australia)

 

Language-Edge.png

 

Language-Chrome.png

 

 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.