Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Midway
Helper I
Helper I

Date Slicer not showing the select the type of slicer check mark Icon on Power BI Service

Hi there, 

 

I am having this issue not being able to see that little check mark Icon on a date slicer so you can change from between to before or after etc.. when I publish the report to Power BI service. What shows is the eraser icon only/

I can see it ok on the desktop tho.

can someone shed a bit of light on this?

 

Thanks for your help in advance.

 

11 REPLIES 11
datamodel
Advocate I
Advocate I

I don't think it's a bug per se, I just think they didn't take this into consideration. There is an idea we can all go vote on 🙂
Microsoft Idea · User can change online date slicer from relative to between (powerbi.com)

And one here:
Microsoft Idea · Date slicer: enable the dropdown menu in PBI service (powerbi.com)

Anonymous
Not applicable

Here, i have another one with exactly the same description and it has slightly more votes, so let's vote on all of these topics! I think it just has to be feature which has to available for users of your reports.
https://ideas.powerbi.com/ideas/idea/?ideaid=6666707b-ad78-450c-898d-7e4961b76155

Midway
Helper I
Helper I

This is gotta to be a bug in the service. Many people are reporting this. How can we escalate this to a higher lever???

Anonymous
Not applicable

I have exactly the same issue. I only see the eraser icon in power bi service, while seeing also a little check mark icon in power bi desktop or when editing a report in service. Anyone a solution?

TrentAssist
Frequent Visitor

@Midway did you ever find a solution to this? I'm having exactly the same issue. 

Same here - no luck.  Date is set to "date" type (not text, not date/time), slicer header is visible, and even tried with Responsive setting as on and off.  The little carrot does not display to provide users the access to change the slicer type when published to the service.

Hello,

 

I've just come across the same issue and accidenly found a way around it. My Dates (type Date) would not show slicer options when I apply them to a new Slicer visualization, however the options (between, before and etc) will appear if you drag the Dates into the existing Slicer with some other data (Text type) already in it. It worked for me, it might work for someone else with a similar issue -)

Hi @OlgaHart , I wasn't so lucky to get this working. Did the dropdown to change between relative and between show up in the Reading view, in the service for you?

v-frfei-msft
Community Support
Community Support

Hi @Midway ,

 

Based on my test using Power BI desktop version  : 2.70.5494.562 64-bit (June 2019).  I cannot repruduce your issue here. Could you please try to update your Power BI desktop to the latest version to check again?

 

https://powerbi.microsoft.com/en-us/desktop/

 

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the others find it more quickly.

Thanks for replyng to my post @v-frfei-msft .  I updated my Power BI version to the latest one but that did not resolve the issue. Its weird, I can see it on Power BI Desktop but when I upload the file to the Power BI service, I only see the eraser icon only, not the check mark icon. Maybe is something that needs to be tweaked in my Power BI service somehow??

 

Thanks for your help.

Hi @Midway ,

 

Could you please have a check whether your date column is date type or text type?

 

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the others find it more quickly.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors