Forum Discussion
Data source credentials and scheduled refresh greyed out
Anonymous , I saw one more use complain same. First, check it is not asking for a gateway. If so , why it is, check do you have any local files used.
Check Know issues -https://docs.microsoft.com/en-us/power-bi/troubleshoot/known-issues/power-bi-known-issues
Log an issue, if needed : https://community.powerbi.com/t5/Issues/idb-p/Issues
- Anonymous2 years agoNot applicable
Hi this actually solved my problem. I have both web and local files used in the data model. I can't schedule auto fresh and my data source credentials is grayed out. Google brought me here for my trouble shooting. After removing the local files, the data source credentials becomes normal and scheduled refresh can be configured. I looked it up in ChatGPT. It explained the reasons for this well. Power BI Service doesn't have direct access to files stored locally. Scheduled refresh requires data sources that are accessible over the internet or a network. Even if PBI Servcie could access local files, managing credentials would be cumbersome and insecure. Plus, local files may not always be available or accessible, if you computer is turned off, disconnected from the network, or if the path is changed. In short, scheduled refresh requires data sources that are consistently available to ensure the reliability and accuracy of your reports and dashboards.
Thank you for your insights! Something new I learned today.
- Anonymous2 years agoNot applicable
Thank you! The local file was the issue!
- sboonefsu1 year agoNew Member
When you talk about storing files locally, I am a bit confused. I utilize powerbi for files that are stored in my onedrive. does this qualify as "stored locally"?
- Anonymous4 years agoNot applicable
Hey Amit,
Thanks for your feedback. UNsure exeactly where to check if the process is asking for a gateway. I presume it would be noted in the error msg. I do not see any reference to a g/w in the error msg.
No local files ONLY access to Az DB tables, so in theory, no g/w should be req'd ..... this is something so fundamental that shouldn't be so convoluted ...... PBI is excellent but this is v unimpressive.
rgds
- v-kkf-msft4 years ago
Community Support
Hi Anonymous ,
If you see option "Use an On-premises or VNet data gateway" enabled on under Gateway connection and it cannot be changed, then the gateway is required for this dataset, like this.
These are some similar threads, please refer to
https://community.powerbi.com/t5/Power-Query/SQL-Azure-Import-Data-Refresh/td-p/88481/page/3
If the problem is still not resolved, please provide detailed error information or the expected result you expect. Let me know immediately, looking forward to your reply.
Best Regards,
Winniz
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.- Anonymous1 year agoNot applicable
Thank you, this was what I needed to be told