Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
Swilam
Regular Visitor

Data labels not showing up on the chart

I'm having a hard time with a chart where I want to see the sales divided by company and displayed in the form of a bar chart. 
On these bars, you have to see how big the difference is from the previous month of this year and from the same month last year. 

this how its looks like with one company (it's already hard to read):
2024-02-26 15_43_17-Greenshot.png

But with more than one company, the data labels do not show up:
2024-02-26 15_49_58-Greenshot.png

 

I'm really open to any idea or suggestion, and I want to add that I'm new to Power BI; I just started a few weeks ago.
Thanks in advance !

1 ACCEPTED SOLUTION
PijushRoy
Super User
Super User

Hi @Swilam 

This is happenning due to many data points.
Please change the Data level orientation to verticals

PijushRoy_0-1708961338472.png

If still having probelm, increase the spacing

PijushRoy_1-1708961447909.png

 

 

2nd Option
Use Clustered bar chart in place of Column chart


 


Let me know if that works for you


If your requirement is solved, please mark THIS ANSWER as SOLUTION ✔️ and help other users find the solution quickly. Please hit the Thumbs Up 👍 button if this comment helps you.

Thanks
Pijush
Linkedin

View solution in original post

3 REPLIES 3
PijushRoy
Super User
Super User

Hi @Swilam 

This is happenning due to many data points.
Please change the Data level orientation to verticals

PijushRoy_0-1708961338472.png

If still having probelm, increase the spacing

PijushRoy_1-1708961447909.png

 

 

2nd Option
Use Clustered bar chart in place of Column chart


 


Let me know if that works for you


If your requirement is solved, please mark THIS ANSWER as SOLUTION ✔️ and help other users find the solution quickly. Please hit the Thumbs Up 👍 button if this comment helps you.

Thanks
Pijush
Linkedin

Hello @PijushRoy,
Thanks for your reply, I tried to increase the spacing before, but it wasn't enough, I think I have to use another chart for this situation. Do you have any suggestion because I tried a lot of possibilities, I can't find the right solution.

Thanks for your time^^

Hi @Swilam 

Did you tried 1st Option, 
Please change the Data level orientation to verticals
I think it will show all data level

If you want to plot many data point in any of visual even custom visual, data level create problem

Better if you use slicer top of the visual.


2nd Option
Use Clustered bar chart in place of Column chart

 


Let me know if that works for you


If your requirement is solved, please mark THIS ANSWER as SOLUTION ✔️ and help other users find the solution quickly. Please hit the Thumbs Up 👍 button if this comment helps you.

Thanks
Pijush
Linkedin

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.