Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
SC_Developer
Regular Visitor

Customer Voice Dataverse Empty Tables

Hi everyone!

 

I try to load Customer Voice tables from Dataverse into Power BI.

 

The survey has been designed, sent out and I can see in the Customer Voice report that there are some responses to it. I made sure to connect to the right Environment with a user that is a Project Owner in Customer Voice and an Admin in Dataverse. But the tables in Dataverse are empty.

 

Do you know why?

 

Thanks for your help.

 

Cheers,

Martin

1 ACCEPTED SOLUTION
v-binbinyu-msft
Community Support
Community Support

Hi @SC_Developer ,

There are a few things that you can check to resolve the issue of empty tables:

1. Refresh the Data: Sometimes, the data may not appear immediately due to sync delays. Ensure that you have refreshed the data in Power BI after the survey responses were submitted.

 

2. Check Table Filters: In Power BI, when connecting to Dataverse, there might be filters applied to the tables that could be excluding the data. Verify that there are no filters preventing the data from being displayed.

 

3. Permissions and Security Roles: Although you mentioned having the necessary permissions, it's worth double-checking that the security roles and permissions are correctly configured to access the survey data in Dataverse. Ensure that the user has the required privileges on the entities used by Customer Voice. For more information on managing user permissions in Customer Voice and Dataverse, please refer to the [security roles documentation](Assign security roles - Power Platform | Microsoft Learn).

 

Best regards,
Community Support Team_Binbin Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
v-binbinyu-msft
Community Support
Community Support

Hi @SC_Developer ,

There are a few things that you can check to resolve the issue of empty tables:

1. Refresh the Data: Sometimes, the data may not appear immediately due to sync delays. Ensure that you have refreshed the data in Power BI after the survey responses were submitted.

 

2. Check Table Filters: In Power BI, when connecting to Dataverse, there might be filters applied to the tables that could be excluding the data. Verify that there are no filters preventing the data from being displayed.

 

3. Permissions and Security Roles: Although you mentioned having the necessary permissions, it's worth double-checking that the security roles and permissions are correctly configured to access the survey data in Dataverse. Ensure that the user has the required privileges on the entities used by Customer Voice. For more information on managing user permissions in Customer Voice and Dataverse, please refer to the [security roles documentation](Assign security roles - Power Platform | Microsoft Learn).

 

Best regards,
Community Support Team_Binbin Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors