Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
Eddies303
Frequent Visitor

Couldn't Load Data For This Visual

Hi,

 

I have a few reports that all have their own dataset.

 

Now I did something new:  I created a second report on an existing dataset.

 

I'm the admin: On my desktop it looked like everything worked fine. But .. when I publish the report to other colleagues the visuals remain empty.  And there is this error in every visual:  couldn't load data for this visual.

 

I have no clue what's going on.   The colleagues I talk about do have access to the report/dataset that I reuse as well.   

 

Do you have any clue what can be wrong?

 

MicrosoftTeams-image (25).png

 

1 ACCEPTED SOLUTION
Eddies303
Frequent Visitor

I have found the reason.

 

First: it probably wasn't the best idea to copy a report and use the copy as a base for building the new report

 

As a result you see my new report "transportkosten"  on top of TWO datasets:   

first on "facturatie_v3" --> that was my intention

second on "transportkosten_v1" -->  this is useless.   I think it wouldn't be created if I had build the second report from scratch.

 

What I had to do:  I had to give the users build-authorisation on the "useless"  dataset "transportkosten_v1".    That solved the problem.

 

 

 

 

Visualistie powerbi 20221121.JPG

View solution in original post

4 REPLIES 4
MariDaen
New Member

In search for solutions, we found a remarcable detail.  As security is quite important to protect data for the company, the addresses for the tables of several sources weren't complete.  We now had to change the addresses with an extra part in the link.  Looking like ".company.local" , in that way all data-sources had to be renamed in order to be accessible for all users in the company.  Maybe this can help?

Eddies303
Frequent Visitor

I have found the reason.

 

First: it probably wasn't the best idea to copy a report and use the copy as a base for building the new report

 

As a result you see my new report "transportkosten"  on top of TWO datasets:   

first on "facturatie_v3" --> that was my intention

second on "transportkosten_v1" -->  this is useless.   I think it wouldn't be created if I had build the second report from scratch.

 

What I had to do:  I had to give the users build-authorisation on the "useless"  dataset "transportkosten_v1".    That solved the problem.

 

 

 

 

Visualistie powerbi 20221121.JPG

Eddies303
Frequent Visitor

MicrosoftTeams-image (27).png

Hi @amitchandak 

 

translated it says "cannot open the visual element"

 

And in the details you'll find this tekst:

 

Activiteits-id: 23ff3b99-8602-4bb6-b85e-6b910aba3b23
Aanvraag-id: 752c1136-f020-6639-ee84-fe2e9a80ab42
Correlatie-id: 35d4e4f1-d98e-7833-41a5-50fe83280fd9
Tijd: Fri Nov 18 2022 16:28:52 GMT+0100 (Midden-Europese standaardtijd)
Serviceversie: 13.0.19445.37
Versie van client: 2211.1.10948-train
URI cluster: https://wabi-west-europe-d-primary-redirect.analysis.windows.net/

 

Best regards,

Eddie

amitchandak
Super User
Super User

@Eddies303 , Copy the error on clipboard and share that

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.