Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
masplin
Impactful Individual
Impactful Individual

Completely foxed why my query has suddenly stopped refreshing

i have had a model running for years pullung static data for various funds from a website.  Suddenly it just wont refresh and refresh just runs forever

 

I have made a small version of ther model with just 4 stocks. Weirdly  the power query while a bit slow it does generate the data I'm expecting i.e. i see it in th power query window. However when i try to bring it inot excelit just spins its wheels.  I did get it to refresh just 1 stock (I have 40 in my real model)

 

I tried turning my excel model into power BI desktop model and same issue.  I've spent days on this and no idea what the issue is as it seems power query is working fine i.e.it isnt a website permissioning issue

 

Example Excel 

 

Really appreciate any advice as took me a long time to build this model

Thanks

Mike

6 REPLIES 6
v-zhengdxu-msft
Community Support
Community Support

Hi @masplin 

 

According to your description, you are trying to get the data of 4 stocks in the website, and this request will successfully get the expected data in PowerQuery, which is not a matter of permissions or access, as you said. But when you refresh your actual model (with 40 shares), you only get 1 share of actual data. You don't get any error messages, which means that the settings are correct on the Power BI side, as evidenced by your mention: the model used to work all the time. I speculate that this site limits the number of requests you can have for a certain period of time. When there is a large number of requests, the website is set to access the load. This may be due to an update to the website's access policy. To prove this, you can try to increase the data request based on 4 stocks to test how many shares the server does not return the data completely, such as 4, 6, 8, and 12 shares.
To further troubleshoot Power BI issues, you can try clearing the cache of Power BI Desktop, taking care to save your credentials. Or is the version of Power BI when your model is working the same as the version you're currently using.

 

Best Regards

Zhengdong Xu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

So its even stranger than that. If I justtake 1 stock I see the results in power query as below

 

Capture.JPG

 

When I refresh in desktop I get this

 

Capture.JPG

 

so same table with the name but no data. see model below. So if it is throttling its doing it on a single request. I asked the wbsite owner and theysaid they hadnt done anything.  I actually dont understand what the difference is the query preview and importin g actualyl into them odel. Its obviously a different process? 

 

assets 

 

Hi @masplin 

 

It's weird, I speculate it might be a bug.

Please consider to create a support ticket to get real-time help.

Here is the steps for creating support ticket.

How to create a Fabric and Power BI Support ticket - Power BI | Microsoft Learn
Power Platform admin center (microsoft.com)

 

Best Regards

Zhengdong Xu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I dont have a pro licence on this account.  I dont have a support plan. i cant seem to ask for support? 

tharunkumarRTK
Solution Sage
Solution Sage

@masplin 

M code in your excel file indicates that you are srapping a website for your data. Have you tried doing the same using python (or any other programming language?). I guess the problem is with the website. Also I tried opening this URL: https://www.theaic.co.uk/companydata/0P00008ZLW&/portfolio and I got 'Page not Found' error.

 


If the post helps please give a thumbs up


If it solves your issue, please accept it as the solution to help the other members find it more quickly.


Tharun

 

So firstly there is no & so use https://www.theaic.co.uk/companydata/0P00008ZLW/portfolio

 

Secondly if you open the query it seems ot run fine within power Query. I would have expected if there was some access/permissioning issue Power Query would fail.  This codehas bene working for several years os no reason to think i need to learn a  new code (I know  nothing of python). I have never had a situation where power query editor is fine but putting it in the model is not. 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

Top Solution Authors