Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Sonal2901
Frequent Visitor

Can't mark table as date table

Hi,

I have a date table using sql query from oracle database. It is in direct query mode.
When I'm trying to mark it as a date table, and select Date Colum, it gets validated successfully but  the OK button is disabled.

I tried changing format from datetime to date but it didn't worked. 

Any help would be appreciated. Thanks

Sonal2901_0-1658833444946.png

 

 

 

2 REPLIES 2
amitchandak
Super User
Super User

@Sonal2901 , It should be a date column without any timestamp. And dates should not repeat. Make sure datatype is date or datetime

It is a date column with timestamp. I tried creating copy of this column removing timestamp in the oracle query but that isn't happening. Used trunc too but it sets the timestamp to midnight rather than removing it.

I can't change its datatype in Power BI because it will make my table to switch to import mode and I need it to be in dual mode. 😞

Helpful resources

Announcements
Fabcon_Europe_Social_Bogo

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors