Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
JGroothedde
Advocate II
Advocate II

Can't add Power BI dataset to local model and vice versa (Premium per user workspace)

Hi everyone,

I am dumbfounded. For a while now it has been impossible for me to connect Desktop to a Premium per user workspace, but only if a local model is involved. What's going on?

For example: when i create a new report in Power BI desktop and connect to my Power BI Dataset that's hosted in a Premium per user workspace, all is fine. Works perfectly. Once i try to add a local model to add another source, even an Excel file, the message below pops up..

JGroothedde_0-1680527900476.png

 

 

Same thing happens when i turn it around. I create a desktop file, add an Excel source to it and then try to connect to a dataset in a premium per user workspace and i get the same message. Very frustrating honestly. Interestingly, this does not occur when connecting to a dataset in an Pro workspace.

What's the deal? Anyone know whether this is a known issue or how to fix this?

 

1 ACCEPTED SOLUTION
JGroothedde
Advocate II
Advocate II

Well. I figured it out. For anyone having the same issue: in our case the culprit was a trailing space behind the name of the dataset. I.E: datasetname .pbix instead of datasetname.pbix.

 

Removing the trailing space solved the issue we've been having for a couple of months now. No wonder i couldn't find anything about it. 

Cheers @amitchandak  for the suggestions. I hope this helps someone else someday, lol.

View solution in original post

3 REPLIES 3
JGroothedde
Advocate II
Advocate II

Well. I figured it out. For anyone having the same issue: in our case the culprit was a trailing space behind the name of the dataset. I.E: datasetname .pbix instead of datasetname.pbix.

 

Removing the trailing space solved the issue we've been having for a couple of months now. No wonder i couldn't find anything about it. 

Cheers @amitchandak  for the suggestions. I hope this helps someone else someday, lol.

amitchandak
Super User
Super User

@JGroothedde , first add a dataset to the empty power bi file, Then make it a direct query using the option in the modeling tab.  And then add an excel file

 

Make sure the login on the desktop has access to dataset

Hi there Amit,

Cheers for the suggestion, unfortunately this doesn't change the outcome. I have verified that desktop has access to the dataset, it easily connects to it. Issues arise when trying to make changes to the local model. I get the screen where you can select the tables you want and then the screenshot above. It fails creating a local model. Again, it works fine when the dataset is hosted in a Pro workspace.

 

I'm stumped haha

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors