Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
julesdude
Post Partisan
Post Partisan

Buttons assigned to bookmarks not working

Hi,

I have 4 visualisation charts overlaid on top of each other and 4 buttons underneath with names to allow the user to click on them to reveal a specific chart from the pile. I have done everything correct and followed all instructions from where I can find it online. I have created 4 bookmarks each named corresponding to the chart they reveal. I have hidden the correct corresponding charts in the selection pane then clicked to update the bookmark with the correpsonding name to save the state of the appearance. For the buttons - I have selected each button in the Selection pane, gone into the Format pane, clicked Action > Type = Bookmark, and Bookmark = the name of the bookmark.

Eventhough selecting the Bookmark state from the Bookmarks pane brings the chart I desire to the top, the buttons themselves don't trigger the bookmark and I can't understand why. 

 

What am I doing wrong?

julesdude_1-1663282965146.png

 

 

 

1 ACCEPTED SOLUTION
v-yalanwu-msft
Community Support
Community Support

Hi, @julesdude ;

If you use a button + bookmark jump in desktop you need Ctrl+ click; but if you pubilc to service. Just click; And the following link is consistent;

 

https://app.powerbi.com/view?r=eyJrIjoiYWQ3N2Q2ZmItNzc3MC00MmRjLTgzZDEtNmMzMmVmNjMxNDAyIiwidCI6ImZiY...


Best Regards,
Community Support Team _ Yalan Wu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
spons
New Member

I had a similar issue where my buttons connected to my bookmarks would not work, even with ctrl+click. (Bookmarks were behaving as expected if I clicked on them from the Bookmarks pane.)

 

I discovered the reason my buttons were unresponsive is because I was using the "Title" property (in General section of the Format pane) to set my button text. For some reason, the Title part of a button is not selectable, it seems. Once I changed all my button labels to use the Text propery (in Button>Style section of the Format pane), the buttons started working as expected.

v-yalanwu-msft
Community Support
Community Support

Hi, @julesdude ;

If you use a button + bookmark jump in desktop you need Ctrl+ click; but if you pubilc to service. Just click; And the following link is consistent;

 

https://app.powerbi.com/view?r=eyJrIjoiYWQ3N2Q2ZmItNzc3MC00MmRjLTgzZDEtNmMzMmVmNjMxNDAyIiwidCI6ImZiY...


Best Regards,
Community Support Team _ Yalan Wu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

julesdude
Post Partisan
Post Partisan

And so....I figured it out by hovering my mouse over the button - a popup explains use CTRL and click here to follow link. I knew it was something simple I was missing!

Are all such button actions activated in the Desktop of the report by having to press CTRL and click? Is this the same when interacting with a report in the Service?

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors