Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Helper II
Helper II

Bug Can't Apply Changes and Save Report

I recently downloaded the most recent version of PBI Desktop from the advanced downloads online. I have an issue now that after adding three new datasources (all MS SQL DBs tables) I can't apply the changes from power query editor. I click apply changes and it evaluates but then just closes the loading page and does not actually add anything to the model. I have tried closing power bi and restarting computer same issue. Tried reinstalling with the repair. Same issue. It doesn't fail and it loads fine in PQE. If I click the close button on the top right, it says I have changes do you want to apply. If I click apply and save it does the same thing. Anyone having this issue too? This is what I see when it runs. 



Frequent Visitor

Apparently, it's a known bug that's being investigated.



Community Support
Community Support

Hi @JaromBIDEVatDK ,


Did you solve your problem? Did the clear cache mentioned by @lbendlin help you?


If you click the refresh button, does the data load properly into the model?

Are there any error messages reported in the Power Query Editor?


Best Regards,

Super User
Super User

Have you tried clearing the cache in the options dialog?

Helpful resources

Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.