Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
mirzay
Helper I
Helper I

Automatic date column drill down not working as advertised

I followed the process in this tutorial here

I have a simple revenue dashboard that I want to display revenue by year, quarter, month, day.

I move the date column (type = date) in the X-Axis and hoping this will enable drill down. Value has the Revenue column. Tried with several bar charts and the table as in the tutorial. The Drill options do not appear in the chart and are greyed out in the menu as well.

Thoughts? Is there an overall config that may need to be enabled?

 

 

9 REPLIES 9
v-haibl-msft
Microsoft Employee
Microsoft Employee

@mirzay

 

Are you using the latest Version: 2.36.4434.381 64-bit (June 2016)? It is strange that it works with a duplicated date column.

It would be helpful if you can provide the .pbix file which can be used to repro it.

 

Best Regards,

Herbert

Herbert Liu, Where should I upload the pbix? I will have to create a new source with just this issue as this is Financial data and cannot be openly shared/published.

@mirzay

 

If possible, you can upload the pbix to OneDrive and share it.

 

Best Regards,

Herbert

Habib
Responsive Resident
Responsive Resident

Right Click on Date in X-Axis under settings and See if "Date" option is selcted or "Hierarchy". It should be hierarchy for drilldown feature.

 

 

All I see is Remove Field and Show Options with no data.

I have a workaround if anyone else expereinces this. I duplicated the Date column as Date_1 in the model and ensured the type was also set to a type Date. If I use this new column, I get the hierarchy and it does what I want to do. 

 

I just marked the original Date column to do not show so there is no confusion when creating reports.

 

Seems like a Power BI bug to me.

You aren't the only one that this is happening to.  it seems like PowerBI isn't recgonizing the field as a date, so by adding a new column using the formula (my example anyway)

 

Act Ship Date = DATEVALUE('Source'[Ship Date]

 

If you do this, then the ship date behaves as expected.

KHorseman
Community Champion
Community Champion

Are you using a dedicated date table or just a date type column in your regular data table?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




This is a date column in a fact table, not the Data table.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.