Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Reply
soyo
Regular Visitor

ArcGIS doesn't keep colors specified - Field Parameters

Hi There, 

1) I set custom colors for my data categories and unselect the category Other

soyo_0-1671481773738.png

2) When I navigate away from this page(more the moment I click away from symbology page) -  colors revert to the default and even my deactivation of category Other is lost 

soyo_1-1671481866775.png

I have tested this outside of the Field Parameters and the settings were kept but I need to switch through parameters. Definitely a bug I think? Any other ideas to go around this out there?

 

Just for context my Field Parameters

Map = {
    ("Wasting", NAMEOF('Table_scenario'[GAM Scenario]), 0),
    ("Overweight", NAMEOF('Table_scenario'[Overweight Scenario]), 1),
    ("Stunting", NAMEOF(Table_scenario[Stunting Scenario]), 2),
    ("Underweight", NAMEOF('Table_scenario'[Underweight Scenario]), 3)
}

Thanks

4 REPLIES 4
PriyankaSS
Frequent Visitor

Hi, I am facing the same issue. Have you managed to find a workaround?

Hi, I changed the data model, all indicators were placed in the color and I used a filter(from a field) to limit the categories and used a slicer to switch across the various filtered versions of the same map (relationships in the data model supported this) instead of fields parameters. Hope its clear and good luck. If not clear I can try to explain more.

soyo
Regular Visitor

@v-henryk-mstf that fact that testing on a singular variable (the same one used in the field paramenters) works means the data is okay - the problem arises when field parameters is introduced. Styles applied are then lost when switching between variables. I none the less tried all the steps you suggested and it did not resolve.

v-henryk-mstf
Community Support
Community Support

Hi @soyo ,

 

If you are experiencing issues with the colors specified in your ArcGIS map not being retained in Power BI, there are a few potential causes for this issue:

  • The ArcGIS map may not be set up to use field-based coloring. In order to use field-based coloring, you will need to specify a field in the "Color By" field in the ArcGIS map visual in Power BI.
  • The data in your ArcGIS map may not have the appropriate values for the field that you are using for coloring. If the field that you are using for coloring contains null or blank values, the ArcGIS map visual may not be able to properly apply the colors.
  • There may be a problem with the data types of the fields that you are using for coloring. The ArcGIS map visual may not be able to apply field-based coloring if the data types of the fields are not compatible with the coloring scheme.

To troubleshoot this issue, you can try the following steps:

  • Check the "Color By" field in the ArcGIS map visual to ensure that it is set up to use field-based coloring.Check the data in your ArcGIS map to ensure that it does not contain any null or blank values for the field that you are using for coloring.
  • Check the data types of the fields that you are using for coloring to ensure that they are compatible with the coloring scheme.

 

If the problem is still not resolved, please provide detailed error information and let me know immediately. Looking forward to your reply.


Best Regards,
Henry


If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.