Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

Regular Visitor

AWS Postgres: 'The remote certificate is invalid'

Hi All, 

I've tried the attached instructions, but I'm still receiving the following error message when trying to connect to AWS RDS Postgres.

Details: "An error happened while reading data from the provider: 'The remote certificate is invalid according to the validation procedure.'" 

Since that post is a couple of years old, I thought I'd ask if there are any additional items to look for? I've installed the latest version of npgsql and imported the AWS RDS Certificates. I'm able to successfully connect to the Database via PgAdmin so it's not an account issue. Any help would be appreciated! 



Not applicable

What worked for me (10 min solution):

I had Postgre DB I was trying to connect to, and because is Postgre connection for some reason in Power BI problematic to connect to and was always ending on the same error as yours did, I tried to connect to the same DB via Rest API (JSON) instead and that worked.

1. Install Zappysys Data Gateway - download 30 days trial here 
2. In Zappysys:
   Data Source tab -> Add ->
   Data Source name = whatever you like to call your connection
   Connector type = Native - ZappySys JSON driver
  -> OK
In next window leave everything as it is, and put your Rest API URL, for ex.
and then bit lower in Settings tab use for HTTP request method = GET

Click on Test connection, it should work.

3. search in your Win search panel for ODBC Data Sources (you should have that already installed with your Power BI installation automatically)
4. in ODBC:
Click on Add -> scroll the whole way down for ZappySys JSON driver -> Finish ->
Data Source Name = whatever you like to call your connection, for. ex. MyEvilPostgre connection -> OK
5. in Power BI
Get data -> ODBC -> choose from the list your connection from ODBC, in our ex. MyEvilPostgre connection. -> OK

6. celebrate after days of torture that your evil connection is finally working

Advocate I
Advocate I

I ran into the same error, and disabling encryption will also make that error go away. 


To disable encryption

  1. File --> Options and settings --> Data source settings
  2. Click Edit Permissions on your connection
  3. Uncheck Encrypt Connections

Hello. Can you help please as when I do the above steps it gives the same error and when I go to edit permissions I find it checked although I unchecked it before?

Sorry, I'm a bit confused.  On step #2 where I'm supposed to click on "Edit Permissions" on my connection, I don't have a connection because of the error I'm getting.  How do I get it to ignore the error and create the connection anyhow so that I can update the Permissions?

In my case I was able to add the connection through the standard "Get Data" and then "Postgresql" data provider, and ran into this after adding it. What does the error you get when adding the new connection? 

Not applicable

This worked. Thank you so much for telling a very simple step.

I literally made an account to just upvote this post. 


I was about to run go down a coding rabbithole to tackle this issue.

Not applicable

Thank you for your post bro, It helped me to solve this problem.

Not applicable

I was also stuck with this issue today. The solution might be obvious to some people but I think it's not clearly mentioned in the other conversation. If you have done everything that is mentioned in the linked instructions than one more thing you should check is that are you using the qualified domain name when connecting to AWS. By this I mean something that ends with I think you just can't use aliases with the AWS certificate. I didn't invent the solution but happened to stumble on it in this community conversation.

Advocate I
Advocate I

@SilvaEric1 Were you able to find a solution or a workaround for this? We are stuck with the same problem

Community Support
Community Support

Hi @SilvaEric1 ,

As tested, I can't reproduce the problem you encountered, please create support ticket .


Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

PBI November 2023 Update Carousel

Power BI Monthly Update - November 2023

Check out the November 2023 Power BI update to learn about new features.

Community News

Fabric Community News unified experience

Read the latest Fabric Community announcements, including updates on Power BI, Synapse, Data Factory and Data Activator.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

Power BI Fabric Summit Carousel

The largest Power BI and Fabric virtual conference

130+ sessions, 130+ speakers, Product managers, MVPs, and experts. All about Power BI and Fabric. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors