Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Anonymous
Not applicable

0x80040E4E Error - OLE DB or ODBC

Hello all.

 

I have this strange error. I say strange because I can refresh the data on the Query Editor but I can't connect it to the model when I do "Apply". I get the 0x80040E4E error and I have literally no idea why. I just know it started occuring after I grabbed data from a folder and I created a function to get the filename in a column.

 

Any thoughts?

 

Thanks in advance!

 

ErrorErrorFuntionFuntion

 

 

1 ACCEPTED SOLUTION
Anonymous
Not applicable

@v-qiuyu-msft

 

After messing around with the file, I solved it. It has to do with character support, as I had cubic and degree sign on the code and it was read as "?". I changed the encoding to Western Europe and it is solved. But it was not intuitive, as the error code did not point to this. Anyway, I hope this may help someone with the same problem.

 

Thanks for your support.

View solution in original post

36 REPLIES 36
martin_mang
Frequent Visitor

Hi, 

 

I have the same issue. In the Power Query I am able to refresh and test the solution and as soon as I Apply changes in the main Power BI window I get these errors. 

 

Data model setup: 

- I am importing all data from a Jira connector. It has worked like this for years, no major SW updates have not occurred

- There are numerous transformations and calculated measures/colums done through M language and DAX

- I am using Import

- SW version 2.116.622.0 64-bit (aprill 2023)

 

What changes have occurred recently: 

- We removed 6 fields from the Jira datamodel on connector level and I have removed these fields from my datamodel (did it twice to make sure I did not make a mistake on the first try with the pbix file). 

- We added one new data field  in Jira and it has been made available in the datamodel.

 

What I have tried so far: 

- Clearing Chaces in the Desktop file. 

- Tested if I kill off a certain tables connections if this will eliminate the issue but NO. 

- Tested datatypes - most of the model is tied together with Jira Issue Key and that is as Text.

- Checked if I remove the new data field from the connector, if this rolls back the issue. But that did not change the situation. 

 

Any reccomendations what to try further?

 

chloesouss
Frequent Visitor

I had the same issue ! Failed to save changes to the server. Error returned: "OLE DB or ODBC error: [DataFormat.Error] The external table is not in the expected format. An unexpected error occurred.  

What can i do to solve it ?

VishaalPatel
Regular Visitor

What worked for me was file --> options -->> Data Load --> Clear Cache on all options

Radovan
New Member

this worked for me,

 

in PowerQuery I calculate integer from datetime (example: "2023-02-07 14:08:52" = "44964")
then if i set column format in PowerBI to date i get error "0x80040E4E Error - OLE DB or ODBC"
if i set the format to whole number everything works correctly

 

so i guess problem is with data format...

 

hopefully it will help someone.

darrenfishell
Advocate II
Advocate II

I'm pulling from a Dataflow and getting this same error and the same vaguely helpful error message. 

Would be excellent if the error identified the fields in question.

Whatever is going wrong here is also not being caught by Table.RemoveRowsWithErrors() either.

darrenfishell_0-1654700946282.png

 

divsforeal
Frequent Visitor

I had the same issue, i had duplicated a table iun power query and this issue poppedup.

It worked for me when i cleared everything in the duplicated table advanced editor and replaced the content from first table(which i duplicated from), then it worked.

 

Hope this helps.

Anonymous
Not applicable

I followed these steps

 

Step 1: Go to the Model section from the left side of the Power BI Desktop

Step 2: Delete all the relationships amongst the tables that have been created by Power BI itself while you were working with the Power Query Editor

Step 3: Click 'Refresh visual and data' option in Home (besides the Transform Data button)

 

It worked and loaded the new data and also applied the automations done in the query editor.

Anonymous
Not applicable

It works...!

This worked for us as well. In addition to the OLE ODBC error we were getting a note about not being able to find data sources we had deleted months ago and were not mentioned anywhere in the model. Thanks!

This saved me so much work, thank you!

Anonymous
Not applicable

Brilliant! This worked for me. 😅

Anonymous
Not applicable

Thank you!! 

dufu
Regular Visitor

Hey there, I ended up through a naive search on the same issue. The 'Solution' post gave me the right indication. It turned out be cause by the filename of the csv files, I was collecting from a sharepoint. Renaming the files, using alphanumeric characters only, solved it for me.

Anonymous
Not applicable

I solved this issue ,Re-install Oracle Client 

 

Anonymous
Not applicable

Hi,
I came across a similar problem but its source was duplicate data on a column that created a relationship with a different table. Even worse, he didn't appear on the table causing the error.

arslaan29
Frequent Visitor

I am trying to get data from Google Analytics to Power Bi but for page and page views field I am getting ' failed to save modifications to the sever . Error returned: 'OLE DB or ODBC error: [DataSource.Error] There was an internal error.. ;. Can you please help me with this issue

v-qiuyu-msft
Community Support
Community Support

Hi @Anonymous,

 

It seems that the error throws out when you apply the changes, right? In your scenario, please try to update the desktop to the version 2.42.4611.901 released in 1/20/2017.

 

If issue persists, please try to share the sample folder data source and sample .pbix file to reproduce the issue if possible.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

@v-qiuyu-msft  i am using the latest PBI november 2020 and still getting similar error (OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E.Object refrence not set to an insatance) . any idea why its still an issue.

Anonymous
Not applicable

@v-qiuyu-msft

 

After messing around with the file, I solved it. It has to do with character support, as I had cubic and degree sign on the code and it was read as "?". I changed the encoding to Western Europe and it is solved. But it was not intuitive, as the error code did not point to this. Anyway, I hope this may help someone with the same problem.

 

Thanks for your support.

Hi,

 

I know this thread is quite old, but maybe someone stumbles over this again. This error seems to have a broad spectrum of possible causes. In my case, it involved some tables being included in the incremental refresh and activating DirectQuery (Power BI Premium) to acquire the latest data. In a few DAX expressions, it broke the LOOKUPVALUE function, and it had a ripple effect on a few other tables.

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Power BI Header Change

Power BI Header Update

Read about the exciting updates for the Power BI forum.