Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
jonocrotz
Frequent Visitor

Dataflow to copy Sharepoint files to Lakehouse, the Destination works for the first query only

Hi All

 

I am currently building a dataflow to copy and transform files in Sharepoint and load them into our Lakehouse.

I have created the first query and successfully create and select the "Lakehouse" as the data destination.

 

However, when I create another query within the same dataflow, I can't select/proceed when trying to connect to the same Lakehouse.

 

First query loading to lakehouse:

jonocrotz_0-1711433163872.png

Second query trying to select Lakehouse as destination: (it just loads and never resolves). Can't proceed or anything.

jonocrotz_1-1711433265238.png

 

 

1 ACCEPTED SOLUTION
jonocrotz
Frequent Visitor

Just circling back to this post, the issue resolved itself a few days after posting. Appears to have been fixed along with alot of other fixes to the platform

View solution in original post

6 REPLIES 6
jonocrotz
Frequent Visitor

Just circling back to this post, the issue resolved itself a few days after posting. Appears to have been fixed along with alot of other fixes to the platform

jonocrotz
Frequent Visitor

@pqian_MSFT , @v-cboorla-msft 

 

I can see the following appear for a brief split second which would allow me to create the connection. But then the window goes back to the original screenshot and the connection tries to load.

 

I can confirm that if I am fast enough, I can click the next button which allows me through this issue.

jonocrotz_0-1711547099032.png

 

That is definitely not expected 🙂 We do not test our customers on their mouse skills.

 

Please do try capturing the network trace, I'd like to FW it to our team to analyze where the bug is.

jonocrotz
Frequent Visitor

Hi @v-cboorla-msft 

 

Thanks for your reply, the clearing of the cache and cookies did not help with the issue.

I've also tried recreating the dataflow from scratch as well as using a new workspace to create the dataflow in, but still not able to create a connection to the lakehouse.

pqian_MSFT
Employee
Employee

@jonocrotz if you can still reproduce this error, can you capture the network logs from the browser and share it with me by private messaging (do not share network logs publicly)

 

1. Open Dev Tools from the browser (usually F12)

2. Go to the network tab

pqian_MSFT_0-1711494647229.png

3. Reproduce the error from scratch

4. Export the network log as HAR

pqian_MSFT_1-1711494669827.png

 

v-cboorla-msft
Community Support
Community Support

Hi @jonocrotz 

 

Thanks for using Microsoft Fabric Community.

Apologies for the inconvenience.

 

The constantly refreshing dropdown in Dataflow Gen2 could be an intermittent issue. To ensure reliable data processing, I recommend you to attempt the select data destination option after a brief period.

Temporary Glitch: Clearing your browser cache and cookies might be beneficial. Corrupted or outdated cached data can sometimes lead to unexpected behavior on websites. Once cleared, please revisit the Dataflow Gen2 interface and attempt the connection again.

 

If the issue still persists, please do let us know. Glad to help.

 

I hope this information helps.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayFBCUpdateCarousel

Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.

Top Solution Authors