Forum Discussion
Issues with Snapshot Isolation Transaction Failures in Cross-Warehouse Ingestion
Thanks for using Microsoft Fabric Community.
This error can occur if you are querying metadata under snapshot isolation and there is a concurrent DDL statement that updates the metadata that is being accessed under snapshot isolation. SQL Server does not support versioning of metadata. For this reason, there are restrictions on what DDL operations can be performed within an explicit transaction running under snapshot isolation.
Please refer the below documentation for additional information.
Link 1 : MSSQLSERVER_3961 - SQL Server | Microsoft Learn
Link 2 : Snapshot isolation transaction fails when querying metadata - Microsoft Community Hub
I hope this information helps. Please do let us know if you have any further queries.
Thank you.
- nguyenhieubis2 years agoFrequent Visitor
Thanks for your response.
I also referred to the two links you mentioned. However, after reviewing my SQL code, I can confirm that I am not using any DDL statements within the TRANSACTION block.
I am only running parallel SQL statements as described in the original problem.
Thank you.
- v-cboorla-msft2 years ago
Microsoft Employee
Could you please confirm whether you are getting above error message on each execution. Or you are observing this error on few executions.
Thank you.
- nguyenhieubis2 years agoFrequent Visitor
For example: In one pipeline run, approximately 12 SQL statements are executed, and one of them will encounter this error. With 10 pipeline runs per day, this error occurs in about 2 runs.