Forum Discussion

jacarmonaro's avatar
jacarmonaro
Frequent Visitor
2 years ago
Solved

Connecting to SQL end point in Fabric from SSMS

Hi folks, I'm having an odd error when I try to connect to the SQL analytics endpoint using SSMS. I am just copying and pasting the SQL connection string from Fabric into SSMS (server name). Then I used my credentials, and I got this error: Insert is not a supported statement type.

To make it clear, I'm not running any query at this point, I'm just trying to establish the connection, and I am getting the same error.

I have seen a couple of posts from other people pointing out the same, but I haven't seen a good answer:

https://community.fabric.microsoft.com/t5/Service/Connecting-to-fabric-SQL-endpoint-from-SSMS/m-p/3278366#:~:text=According%20to%20your%20error%20message,SQL%20Endpoint%20of%20the%20Lakehouse.

 

Any help would be appreciated

  • Hi jacarmonaro,

     

    My bad. It is Error list and Output

     

     

    Also, while connecting to the SQL endpoint, try giving the exact lakehouse name as database by going to options. 

     

     

    In terms of permissions, I guess you are good. It's just that the workspace can have multiple lakehouses/warehouses to which you might not have access. 

5 Replies

  • Hi jacarmonaro ,

     

    In SSMS, Go to View -> Select Error messages and output box. Now try to connect to the SQL endpoint and look at the queries that are fired. 

     

    When I connected my lakehouse, I can see that in the backend, a temp table is created and then names of the databases are inserted into that table.

     

     

    You might not have the access to read the data at that level, you can try specifiying a particular database to connect to, which in this case a lakehouse/warehouse name. 

     

    The endpoint is the same across the workspace. So in case you were provided access to only one lakehouse/warehouse in the workspace, then I think that might be the reason you are getting this issue. 

    • jacarmonaro's avatar
      jacarmonaro
      Frequent Visitor

      Thank you for replying. I have not been able to find this option is SSMS: View -> Select Error messages and output box. Can you double-check the option name, please?

      The owner of the lakehouse also assigned me as owner, but I am still having the same issue. Any idea of the type of permission I should get?

       

      Thank you again!

       

      • govindarajan_d's avatar
        govindarajan_d
        Icon for Super User rankSuper User

        Hi jacarmonaro,

         

        My bad. It is Error list and Output

         

         

        Also, while connecting to the SQL endpoint, try giving the exact lakehouse name as database by going to options. 

         

         

        In terms of permissions, I guess you are good. It's just that the workspace can have multiple lakehouses/warehouses to which you might not have access. 

  • jacarmonaro's avatar
    jacarmonaro
    Frequent Visitor

    Hi, for those who may still be experiencing this issue, the fix was easy. I just updated the version of SSMS. I was using v18.6, and after upgrading to 19.3, the issue disappeared.